summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdevelop
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-base/tdevelop
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdevelop')
-rw-r--r--trinity-base/tdevelop/Manifest1
-rw-r--r--trinity-base/tdevelop/tdevelop-14.0.13.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-base/tdevelop/Manifest b/trinity-base/tdevelop/Manifest
index e4df9bbe..1dc989ee 100644
--- a/trinity-base/tdevelop/Manifest
+++ b/trinity-base/tdevelop/Manifest
@@ -1 +1,2 @@
DIST tdevelop-trinity-14.0.12.tar.xz 6463524 BLAKE2B dacc3f2c7d634b1e0723e2096099464f78a79ac852ce367cbd4bdb7f04967995b8751794777200766620a419016dbcd183573b7041690404d922a7be4aadcdd5 SHA512 862bafe1eb68dc371f0b9d9648321fae5dc36c5499e8a551e7b52967d23f67ad5fc05630c9f988413c4ccece8d50572e04447e01ae8d00c0cdff7e30edc1d002
+DIST tdevelop-trinity-14.0.13.tar.xz 6463204 BLAKE2B 8d9653860b74bbbbb8cb8aa874f37a932cfd6e045042ccf2013376a8602e587fa23094a0814c995164aa6f8afa5b32da8448a2c1c61dc446cf3eac71b93244f8 SHA512 617265e124588b23d268fdbb730b7af7471de584df2a8530af0ac5bd35c901a3dd495a934b86ad0dd43aeeb3a1082d6e499b02a3f46ca559359e0742e18afd86
diff --git a/trinity-base/tdevelop/tdevelop-14.0.13.ebuild b/trinity-base/tdevelop/tdevelop-14.0.13.ebuild
new file mode 100644
index 00000000..947eebc4
--- /dev/null
+++ b/trinity-base/tdevelop/tdevelop-14.0.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_HANDBOOK="optional"
+
+TRINITY_MODULE_TYPE="core"
+inherit trinity-base-2
+
+DESCRIPTION="The TDevelop Integrated Development Environment"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="dev-lang/perl
+ net-dns/libidn
+ sys-libs/db
+ virtual/acl"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ pushd "${S}/parts/appwizard/common/" || die
+ trinity-admin-prepare
+ popd
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LANGUAGE_ALL=ON
+ -DWITH_BUILDTOOL_ALL=ON
+ -DBUILD_ALL=ON
+ )
+
+ trinity-base-2_src_configure
+}