summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdevelop
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/tdevelop
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdevelop')
-rw-r--r--trinity-base/tdevelop/Manifest1
-rw-r--r--trinity-base/tdevelop/tdevelop-14.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-base/tdevelop/Manifest b/trinity-base/tdevelop/Manifest
index 5dfda7fa..518a9600 100644
--- a/trinity-base/tdevelop/Manifest
+++ b/trinity-base/tdevelop/Manifest
@@ -1 +1,2 @@
DIST tdevelop-trinity-14.0.13.tar.xz 6463204 BLAKE2B 8d9653860b74bbbbb8cb8aa874f37a932cfd6e045042ccf2013376a8602e587fa23094a0814c995164aa6f8afa5b32da8448a2c1c61dc446cf3eac71b93244f8 SHA512 617265e124588b23d268fdbb730b7af7471de584df2a8530af0ac5bd35c901a3dd495a934b86ad0dd43aeeb3a1082d6e499b02a3f46ca559359e0742e18afd86
+DIST tdevelop-trinity-14.1.0.tar.xz 6463536 BLAKE2B 5ec22aca514e6c99563ce064a6543c32708772d7feac92bc019882f0bc45a091c6ab52369f4d6c36dcac9b1745539d8754ac4fec4603d993cd18822045833036 SHA512 f111522eacff9a6a65e7af1a81e51180bd9b19b629fe4fe3bc6cf5f8bb28ddc391ad9686c44cd1e2a7bd8879f2e65b3a44967303399b5ef70bae601174f07d97
diff --git a/trinity-base/tdevelop/tdevelop-14.1.0.ebuild b/trinity-base/tdevelop/tdevelop-14.1.0.ebuild
new file mode 100644
index 00000000..2ca68c66
--- /dev/null
+++ b/trinity-base/tdevelop/tdevelop-14.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_HANDBOOK="optional"
+
+TRINITY_MODULE_TYPE="core"
+inherit trinity-base-2
+
+DESCRIPTION="The TDevelop Integrated Development Environment"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="dev-lang/perl
+ net-dns/libidn
+ sys-libs/db
+ virtual/acl"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ pushd "${S}/parts/appwizard/common/" || die
+ trinity-admin-prepare
+ popd
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LANGUAGE_ALL=ON
+ -DWITH_BUILDTOOL_ALL=ON
+ -DBUILD_ALL=ON
+ )
+
+ trinity-base-2_src_configure
+}