summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdevelop
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/tdevelop
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdevelop')
-rw-r--r--trinity-base/tdevelop/Manifest1
-rw-r--r--trinity-base/tdevelop/tdevelop-14.0.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-base/tdevelop/Manifest b/trinity-base/tdevelop/Manifest
new file mode 100644
index 00000000..610160a9
--- /dev/null
+++ b/trinity-base/tdevelop/Manifest
@@ -0,0 +1 @@
+DIST tdevelop-trinity-14.0.11.tar.xz 6462352 BLAKE2B 5ecfdd132eac96795657ad93588384e0d7778fd81621057e7eec86558f98261b60d7d71d0c6459dd4c53e61b9ee369a62ec1db40d170f7a0853fb498e2c24b2d SHA512 47b6a56e8ce8f6d232c9db6b4f36c8c8b16af9905a2329ba7dfe0c348acee65e23869e04eab7d8b4cfe4f15b71111b960c8a543cb95fa8fb98617d27dd63fdf2
diff --git a/trinity-base/tdevelop/tdevelop-14.0.11.ebuild b/trinity-base/tdevelop/tdevelop-14.0.11.ebuild
new file mode 100644
index 00000000..af26e9db
--- /dev/null
+++ b/trinity-base/tdevelop/tdevelop-14.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_HANDBOOK="optional"
+
+TRINITY_MODULE_TYPE="core"
+inherit trinity-base-2
+
+DESCRIPTION="The TDevelop Integrated Development Environment"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-lang/perl
+ net-dns/libidn
+ virtual/acl"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ pushd "${S}/parts/appwizard/common/" || die
+ trinity-admin-prepare
+ popd
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LANGUAGE_ALL=ON
+ -DWITH_BUILDTOOL_ALL=ON
+ -DBUILD_ALL=ON
+ )
+
+ trinity-base-2_src_configure
+}