summaryrefslogtreecommitdiffstats
path: root/trinity-base/twin
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-08 19:09:38 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:33:02 +0000
commit13f3b6432f125802f4fee3827d2b0e882a0a8dfe (patch)
tree49224d9604584a2ad827891fd6667cbf412a6385 /trinity-base/twin
parente05ee6fdde9c2c4b00dbe2c4e5a82da8141a64e2 (diff)
downloadtde-packaging-gentoo-13f3b6432f125802f4fee3827d2b0e882a0a8dfe.tar.gz
tde-packaging-gentoo-13f3b6432f125802f4fee3827d2b0e882a0a8dfe.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 3.
This time: kpager, krootbacking, ksplashml, kstart, ksystraycmd, kxkb, nsplugins, tdebase-starttde, tdedebugdialog, tdeeject, tdepasswd, tdeprint, tdescreensaver, tdesu and tqt3integration Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/twin')
-rw-r--r--trinity-base/twin/twin-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/trinity-base/twin/twin-9999.ebuild b/trinity-base/twin/twin-9999.ebuild
index 73fc9d40..b6d143d7 100644
--- a/trinity-base/twin/twin-9999.ebuild
+++ b/trinity-base/twin/twin-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta eutils
+inherit trinity-meta-2 eutils
DESCRIPTION="Trinity window manager"
-KEYWORDS=
+
IUSE="xcomposite xrandr xinerama +libconfig +pcre opengl"
DEPEND="x11-libs/libXext
@@ -23,16 +24,16 @@ RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with xcomposite XCOMPOSITE)
- $(cmake-utils_use_with xcomposite XFIXES)
- $(cmake-utils_use_with xcomposite XRENDER)
- $(cmake-utils_use_with xrandr XRANDR)
- $(cmake-utils_use_with libconfig LIBCONFIG)
- $(cmake-utils_use_with pcre PCRE)
- $(cmake-utils_use_with xinerama XINERAMA)
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ -DWITH_XFIXES="$(usex xcomposite)"
+ -DWITH_XRENDER="$(usex xcomposite)"
+ -DWITH_XRANDR="$(usex xrandr)"
+ -DWITH_LIBCONFIG="$(usex libconfig)"
+ -DWITH_PCRE="$(usex pcre)"
+ -DWITH_XINERAMA="$(usex xinerama)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
pkg_postinst() {