summaryrefslogtreecommitdiffstats
path: root/x11-libs/tqscintilla
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /x11-libs/tqscintilla
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'x11-libs/tqscintilla')
-rw-r--r--x11-libs/tqscintilla/Manifest1
-rw-r--r--x11-libs/tqscintilla/tqscintilla-14.1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/tqscintilla/Manifest b/x11-libs/tqscintilla/Manifest
index a1b264d1..63ac27f4 100644
--- a/x11-libs/tqscintilla/Manifest
+++ b/x11-libs/tqscintilla/Manifest
@@ -1 +1,2 @@
DIST tqscintilla-trinity-14.1.1.tar.xz 654132 BLAKE2B ec0d8e5a023db94eb9cddad2db6a44848aa179cf36b28a50b80575c409e1889ad3ab38d8aa90da663d7779da0996a666b2007af8442c75a3b2243e5c98e02ddb SHA512 d54799af4ceca0e864ae9169d7e1ef8cd82c2b1efd543dec6f5e10d20e34f39f80f52d7f433af620d8c929fa762405eb84a469bddb9123544a82a679705d43e8
+DIST tqscintilla-trinity-14.1.2.tar.xz 654020 BLAKE2B 63689a3e997d832f85cba2ea5e87eb495c35a1cae36331bc910de386c21d4528b2f629f4470b945368fb248c653022b3482a17663f1d49a75ef3181e44e9aba2 SHA512 55f0fdbb009b19a92cc74c954ba3c2472831b6e4ce40151401197aa8c88654ef040752a0176dce8c055a954333820df339df93cb5476341b8dd99e36310b56a5
diff --git a/x11-libs/tqscintilla/tqscintilla-14.1.2.ebuild b/x11-libs/tqscintilla/tqscintilla-14.1.2.ebuild
new file mode 100644
index 00000000..7c204d83
--- /dev/null
+++ b/x11-libs/tqscintilla/tqscintilla-14.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="tqscintilla"
+
+inherit trinity-base-2
+
+DESCRIPTION="TQt source code editing component based on Scintilla"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}${TQBASE}"
+ -DHTML_INSTALL_DIR="${TDEDIR}/share/doc/tde/HTML"
+ -DBUILD_ALL=ON
+ )
+ trinity-base-2_src_configure
+}