summaryrefslogtreecommitdiffstats
path: root/x11-wm/compiz/files
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-11-03 13:25:23 +0300
committerormorph <roma251078@mail.ru>2023-11-03 13:25:23 +0300
commit09c45f2ef3b79c2e0abc65dbf5f586d187e9178c (patch)
tree16899bf8a31724bf888134e14f67d82ebe8ca373 /x11-wm/compiz/files
parent401e8e54e08f17f50eb0140cf823410b30b3ac19 (diff)
downloadtde-packaging-gentoo-09c45f2ef3b79c2e0abc65dbf5f586d187e9178c.tar.gz
tde-packaging-gentoo-09c45f2ef3b79c2e0abc65dbf5f586d187e9178c.zip
Added x11-wm/compiz package
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'x11-wm/compiz/files')
-rw-r--r--x11-wm/compiz/files/access_violation.patch18
-rw-r--r--x11-wm/compiz/files/gtk-extents.patch13
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/compiz/files/access_violation.patch b/x11-wm/compiz/files/access_violation.patch
new file mode 100644
index 00000000..12df855b
--- /dev/null
+++ b/x11-wm/compiz/files/access_violation.patch
@@ -0,0 +1,18 @@
+--- compiz-9999/compizconfig/libcompizconfig/config/CMakeLists.txt.orig 2015-02-03 12:09:12.000000000 +0100
++++ compiz-9999/compizconfig/libcompizconfig/config/CMakeLists.txt 2015-06-14 13:12:15.009100624 +0200
+@@ -4,4 +4,4 @@
+ configure_file (${CMAKE_CURRENT_SOURCE_DIR}/config_test
+ ${CMAKE_CURRENT_BINARY_DIR}/compiz-1/compizconfig/config)
+
+-install (FILES ${_config_file} DESTINATION ${COMPIZCONFIG_CONFIG_DIR})
++install (FILES ${_config_file} DESTINATION $ENV{DESTDIR}${COMPIZCONFIG_CONFIG_DIR})
+--- compiz-9999/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake.orig 2016-08-01 22:56:04.317994940 +0200
++++ compiz-9999/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2016-08-01 22:58:03.707528553 +0200
+@@ -18,6 +18,6 @@
+ if (GLIB_COMPILE_SCHEMAS)
+
+ message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
+- execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
++ execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} \"$ENV{DESTDIR}${SCHEMADIR}\")
+
+ endif (GLIB_COMPILE_SCHEMAS)
diff --git a/x11-wm/compiz/files/gtk-extents.patch b/x11-wm/compiz/files/gtk-extents.patch
new file mode 100644
index 00000000..5c8ec1ec
--- /dev/null
+++ b/x11-wm/compiz/files/gtk-extents.patch
@@ -0,0 +1,13 @@
+# Diff from https://code.launchpad.net/~albertsmuktupavels/compiz/add-gtk-frame-extents-to-net-supported/+merge/257303
+=== modified file 'src/screen.cpp'
+--- a/src/screen.cpp 2014-12-02 19:37:10 +0000
++++ b/src/screen.cpp 2015-04-23 20:41:24 +0000
+@@ -2362,6 +2362,7 @@
+
+ atoms.push_back (Atoms::wmUserTime);
+ atoms.push_back (Atoms::frameExtents);
++ atoms.push_back (Atoms::frameGtkExtents);
+ atoms.push_back (Atoms::frameWindow);
+
+ atoms.push_back (Atoms::winState);
+