summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--trinity-base/arts/arts-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/trinity-base/arts/arts-9999.ebuild b/trinity-base/arts/arts-9999.ebuild
index 155b8bf3..f54ad351 100644
--- a/trinity-base/arts/arts-9999.ebuild
+++ b/trinity-base/arts/arts-9999.ebuild
@@ -15,28 +15,27 @@ DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output m
HOMEPAGE="http://trinitydesktop.org/"
LICENSE="|| ( GPL-2 GPL-3 )"
-IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
-SLOT="$TRINITY_VER"
+IUSE="alsa -artswrappersuid jack mp3 vorbis"
+SLOT="${TRINITY_VER}"
DEPEND="=dev-tqt/tqtinterface-${PV}
dev-libs/glib
media-libs/audiofile
mp3? ( media-libs/libmad )
- nas? ( media-libs/nas )
alsa? ( media-libs/alsa-lib )
vorbis? ( media-libs/libogg media-libs/libvorbis )
jack? ( media-sound/jack-audio-connection-kit )"
-RDEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
- -DAUDIOFILE=ON
+ -DWITH_AUDIOFILE=ON
-DWITH_MAD="$(usex mp3)"
- -DWITH_NAS="$(usex nas)"
-DWITH_ALSA="$(usex alsa)"
-DWITH_VORBIS="$(usex vorbis)"
-DWITH_JACK="$(usex jack)"
- # NOTE: WITH_ESD dropped due to remove of esound long ago
+ -DWITH_ESOUND=OFF
+ -DWITH_SNDIO=OFF
)
trinity-base-2_src_configure
@@ -45,16 +44,16 @@ src_configure() {
src_install() {
trinity-base-2_src_install
- # used for realtime priority, but off by default as it is a security hazard
- use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
+ # Used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${TDEDIR}/bin/artswrapper"
}
pkg_postinst() {
if ! use artswrappersuid ; then
- elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
- elog "and so avoid possible skips in sound. However, on untrusted systems this"
- elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "Run chmod u+s ${TDEDIR}/bin/artswrapper to let artsd use realtime"
+ elog "priority and so avoid possible skips in sound. However, on untrusted systems"
+ elog "this creates the possibility of a DoS attack that'll use 100% cpu at realtime"
elog "priority, and so is off by default. See Gentoo bug #7883."
- elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ elog "Or, you can set the artswrappersuid USE flag to make the ebuild do this."
fi
}