summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild17
-rw-r--r--trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.7.ebuild17
-rw-r--r--trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild18
3 files changed, 28 insertions, 24 deletions
diff --git a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
index cf230cf9..41100ff3 100644
--- a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
+++ b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_NAME="tdebase"
inherit trinity-meta-2
TSM_EXTRACT="tdeioslave"
DESCRIPTION="Generic Trinity TDEIOslaves"
KEYWORDS="~amd64 ~x86"
-IUSE="samba ldap sasl openexr +hwlib"
+IUSE="+hwlib ldap openexr samba sasl"
-DEPEND="x11-libs/libXcursor
+DEPEND="
net-libs/rpcsvc-proto
+ x11-libs/libXcursor
+ ldap? ( net-nds/openldap )
openexr? ( media-libs/openexr )
samba? ( net-fs/samba )
- ldap? ( net-nds/openldap )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${DEPEND}
- virtual/ssh
- ~trinity-base/tdeeject-${PV}"
+ ~trinity-base/tdeeject-${PV}
+ virtual/ssh"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_XCURSOR=ON
-DWITH_SAMBA="$(usex samba)"
-DWITH_LDAP="$(usex ldap)"
diff --git a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.7.ebuild b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.7.ebuild
index cf230cf9..41100ff3 100644
--- a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.7.ebuild
+++ b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.7.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_NAME="tdebase"
inherit trinity-meta-2
TSM_EXTRACT="tdeioslave"
DESCRIPTION="Generic Trinity TDEIOslaves"
KEYWORDS="~amd64 ~x86"
-IUSE="samba ldap sasl openexr +hwlib"
+IUSE="+hwlib ldap openexr samba sasl"
-DEPEND="x11-libs/libXcursor
+DEPEND="
net-libs/rpcsvc-proto
+ x11-libs/libXcursor
+ ldap? ( net-nds/openldap )
openexr? ( media-libs/openexr )
samba? ( net-fs/samba )
- ldap? ( net-nds/openldap )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${DEPEND}
- virtual/ssh
- ~trinity-base/tdeeject-${PV}"
+ ~trinity-base/tdeeject-${PV}
+ virtual/ssh"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_XCURSOR=ON
-DWITH_SAMBA="$(usex samba)"
-DWITH_LDAP="$(usex ldap)"
diff --git a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
index 3f1bc77d..988ceeb4 100644
--- a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
+++ b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
@@ -1,30 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_NAME="tdebase"
inherit trinity-meta-2
TSM_EXTRACT="tdeioslave"
DESCRIPTION="Generic Trinity TDEIOslaves"
-IUSE="samba ldap sasl openexr +hwlib"
-DEPEND="x11-libs/libXcursor
+IUSE="+hwlib ldap openexr samba sasl"
+
+DEPEND="
net-libs/rpcsvc-proto
+ x11-libs/libXcursor
+ ldap? ( net-nds/openldap )
openexr? ( media-libs/openexr )
samba? ( net-fs/samba )
- ldap? ( net-nds/openldap )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${DEPEND}
- virtual/ssh
- ~trinity-base/tdeeject-${PV}"
+ ~trinity-base/tdeeject-${PV}
+ virtual/ssh"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_XCURSOR=ON
-DWITH_SAMBA="$(usex samba)"
-DWITH_LDAP="$(usex ldap)"