summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--profiles/package.use.force7
-rw-r--r--trinity-apps/kaffeine/kaffeine-9999.ebuild6
2 files changed, 9 insertions, 4 deletions
diff --git a/profiles/package.use.force b/profiles/package.use.force
index ed663958..fe4581de 100644
--- a/profiles/package.use.force
+++ b/profiles/package.use.force
@@ -1,3 +1,8 @@
# Chris (2020-04-22)
# Building without tdehwlib segfaults, but you can try and report.
-=trinity-libs/tdelibs-9999 hwlib \ No newline at end of file
+=trinity-base/tdelibs-9999 hwlib
+
+Chris (2020-04-22)
+# As of today Kaffeine can be only build with xinerama support.
+# If that is fixed, the build option will be optional again.
+trinity-apps/kaffeine xinerama \ No newline at end of file
diff --git a/trinity-apps/kaffeine/kaffeine-9999.ebuild b/trinity-apps/kaffeine/kaffeine-9999.ebuild
index 7e8cfd6b..3a04ae95 100644
--- a/trinity-apps/kaffeine/kaffeine-9999.ebuild
+++ b/trinity-apps/kaffeine/kaffeine-9999.ebuild
@@ -21,7 +21,7 @@ need-trinity
SLOT="${TRINITY_VER}"
-IUSE+=" dvb dpms gstreamer vorbis encode xcb"
+IUSE+=" dvb dpms gstreamer vorbis encode xcb xinerama"
# As of April 2020 Kaffeine can be only build with xinerama support.
# If that is fixed, the build option will be optional again.
@@ -38,7 +38,7 @@ DEPEND+="
encode? ( media-sound/lame )
vorbis? ( media-libs/libvorbis )
xcb? ( x11-libs/libxcb )
- x11-libs/libXinerama
+ xinerama? ( x11-libs/libXinerama )
dvb? ( virtual/linuxtv-dvb-headers )"
RDEPEND+=" ${DEPEND}"
@@ -47,7 +47,7 @@ src_configure() {
-DBUILD_TRANSLATIONS=ON
-DWITH_XTEST=ON
-DWITH_DPMS="$(usex dpms)"
- -DWITH_XINERAMA=ON
+ -DWITH_XINERAMA="$(usex xinerama)"
-DWITH_XCB="$(usex xcb)"
-DWITH_GSTREAMER="$(usex gstreamer)"
-DWITH_OGGVORBIS="$(usex vorbis)"