summaryrefslogtreecommitdiffstats
path: root/Documentation/scripts/create_list_keywords.sh
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/scripts/create_list_keywords.sh')
-rwxr-xr-xDocumentation/scripts/create_list_keywords.sh20
1 files changed, 20 insertions, 0 deletions
diff --git a/Documentation/scripts/create_list_keywords.sh b/Documentation/scripts/create_list_keywords.sh
new file mode 100755
index 00000000..368b6b47
--- /dev/null
+++ b/Documentation/scripts/create_list_keywords.sh
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+##################################################################################################
+# cd PATH/tde-packaging-gentoo
+# Documentation/scripts/create_list_keywords.sh 9999 >/etc/portage/package.accept_keywords/trinity
+##################################################################################################
+
+VERS=$1
+create_list() {
+ local FILE STR ARRAY
+ while read file
+ do
+ FILE=${file//.\//}
+ STR=${FILE%.ebuild}
+ ARRAY=(${STR//\// })
+ echo "~${ARRAY[0]}/${ARRAY[2]} **"
+ done < <(find -type f -name "*-${VERS}.ebuild")
+}
+
+create_list | sort