summaryrefslogtreecommitdiffstats
path: root/eclass/trinity-functions-2.eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/trinity-functions-2.eclass')
-rw-r--r--eclass/trinity-functions-2.eclass72
1 files changed, 36 insertions, 36 deletions
diff --git a/eclass/trinity-functions-2.eclass b/eclass/trinity-functions-2.eclass
index aaae5be2..8ccdb86a 100644
--- a/eclass/trinity-functions-2.eclass
+++ b/eclass/trinity-functions-2.eclass
@@ -211,53 +211,53 @@ trinity_l10n_for_each_locale_do() {
# @DESCRIPTION:
# This function prepares the source for building.
trinity-admin-prepare() {
- pushd "${PWD}/admin"
- libtoolize -c || die "Error libtoolize"
- cp -Rp /usr/share/aclocal/libtool.m4 "libtool.m4.in" || die "No such file: libtool.m4"
+ pushd "${PWD}/admin"
+ libtoolize -c || die "Error libtoolize"
+ cp -Rp /usr/share/aclocal/libtool.m4 "libtool.m4.in" || die "No such file: libtool.m4"
cp -Rp /usr/share/libtool/build-aux/config.* . || die
- popd
+ popd
}
# @FUNCTION: trinity-gen-configure
# @DESCRIPTION:
# This function generates a configure script to build.
trinity-gen-configure() {
- trinity-admin-prepare
- emake -f admin/Makefile.common || die "Error creating configuration"
+ trinity-admin-prepare
+ emake -f admin/Makefile.common || die "Error creating configuration"
}
# @FUNCTION: trinity-econf
# @DESCRIPTION:
# This function configures the assembly.
trinity-econf() {
- local myconf
- myconf=(--prefix="${TDEDIR}"
- --bindir="${TDEDIR}/bin"
- --datadir="${TDEDIR}/share"
- --includedir="${TDEDIR}/include"
- --libdir="${TDEDIR}/$(get_libdir)"
- --disable-dependency-tracking
- --enable-new-ldflags
- --enable-final
- --enable-closure
- --enable-rpath)
-
- if has "debug" ${IUSE} || has "-debug" ${IUSE} || has "+debug" ${IUSE}; then
- use debug && myconf+=(--enable-debug=yes) || myconf+=(--disable-debug)
- else
- myconf+=(--disable-debug)
- fi
-
- if [[ "${TRINITY_NEED_ARTS}" == "yes" ]]; then
- echo "configure ${myconf[@]} $@"
- ./configure ${myconf[@]} $@ || die "Error creating configuration"
- elif [[ "${TRINITY_NEED_ARTS}" == "optional" ]]; then
- use arts || myconf+=(--without-arts)
- echo "./configure ${myconf[@]} $@"
- build_arts=$(usex arts yes no) ./configure ${myconf[@]} $@ || die "Error creating configuration"
- else
- myconf+=(--without-arts)
- echo "./configure ${myconf[@]} $@"
- build_arts=no ./configure ${myconf[@]} $@ || die "Error creating configuration"
- fi
+ local myconf
+ myconf=(--prefix="${TDEDIR}"
+ --bindir="${TDEDIR}/bin"
+ --datadir="${TDEDIR}/share"
+ --includedir="${TDEDIR}/include"
+ --libdir="${TDEDIR}/$(get_libdir)"
+ --disable-dependency-tracking
+ --enable-new-ldflags
+ --enable-final
+ --enable-closure
+ --enable-rpath)
+
+ if has "debug" ${IUSE} || has "-debug" ${IUSE} || has "+debug" ${IUSE}; then
+ use debug && myconf+=(--enable-debug=yes) || myconf+=(--disable-debug)
+ else
+ myconf+=(--disable-debug)
+ fi
+
+ if [[ "${TRINITY_NEED_ARTS}" == "yes" ]]; then
+ echo "configure ${myconf[@]} $@"
+ ./configure ${myconf[@]} $@ || die "Error creating configuration"
+ elif [[ "${TRINITY_NEED_ARTS}" == "optional" ]]; then
+ use arts || myconf+=(--without-arts)
+ echo "./configure ${myconf[@]} $@"
+ build_arts=$(usex arts yes no) ./configure ${myconf[@]} $@ || die "Error creating configuration"
+ else
+ myconf+=(--without-arts)
+ echo "./configure ${myconf[@]} $@"
+ build_arts=no ./configure ${myconf[@]} $@ || die "Error creating configuration"
+ fi
}