summaryrefslogtreecommitdiffstats
path: root/trinity-apps/chalk/chalk-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/chalk/chalk-9999.ebuild')
-rw-r--r--trinity-apps/chalk/chalk-9999.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/trinity-apps/chalk/chalk-9999.ebuild b/trinity-apps/chalk/chalk-9999.ebuild
index 1fcc6fae..f9f3c739 100644
--- a/trinity-apps/chalk/chalk-9999.ebuild
+++ b/trinity-apps/chalk/chalk-9999.ebuild
@@ -1,5 +1,5 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -8,7 +8,7 @@ TRINITY_MODULE_NAME="koffice"
TRINITY_MODULE_TYPE="applications/office"
TRINITY_BUILD_ADMIN="yes"
TRINITY_SUBMODULE="chalk filters/chalk"
-TSM_EXTRACT_ALSO="lib interfaces"
+TSM_EXTRACT_ALSO="lib interfaces doc"
inherit trinity-meta-2
@@ -19,7 +19,7 @@ SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
+IUSE="+handbook"
DEPEND="~dev-tqt/tqt-${PV}[opengl]
media-libs/lcms:0=
@@ -32,8 +32,9 @@ DEPEND="~dev-tqt/tqt-${PV}[opengl]
virtual/jpeg
virtual/imagemagick-tools[tiff]
"
-
-RDEPEND="$DEPEND"
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
KMCOPYLIB="
libkformula lib/kformula
@@ -75,6 +76,10 @@ src_prepare() {
fi
done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+
echo "SUBDIRS=$dirlist kross" > ${S}/lib/Makefile.am
echo "SUBDIRS= api main" > ${S}/lib/kross/Makefile.am
echo "SUBDIRS= chalk" >${S}/filters/Makefile.am
@@ -98,3 +103,12 @@ src_compile() {
done
trinity-meta-2_src_compile
}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}