summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kaffeine/kaffeine-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kaffeine/kaffeine-9999.ebuild')
-rw-r--r--trinity-apps/kaffeine/kaffeine-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/trinity-apps/kaffeine/kaffeine-9999.ebuild b/trinity-apps/kaffeine/kaffeine-9999.ebuild
index 9cb2c909..7e8cfd6b 100644
--- a/trinity-apps/kaffeine/kaffeine-9999.ebuild
+++ b/trinity-apps/kaffeine/kaffeine-9999.ebuild
@@ -1,5 +1,6 @@
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
+
EAPI="7"
TRINITY_MODULE_TYPE="applications"
@@ -20,7 +21,10 @@ need-trinity
SLOT="${TRINITY_VER}"
-IUSE+=" dvb dpms gstreamer xinerama vorbis encode xcb"
+IUSE+=" dvb dpms gstreamer vorbis encode xcb"
+
+# As of April 2020 Kaffeine can be only build with xinerama support.
+# If that is fixed, the build option will be optional again.
DEPEND+="
x11-base/xorg-proto
@@ -34,6 +38,7 @@ DEPEND+="
encode? ( media-sound/lame )
vorbis? ( media-libs/libvorbis )
xcb? ( x11-libs/libxcb )
+ x11-libs/libXinerama
dvb? ( virtual/linuxtv-dvb-headers )"
RDEPEND+=" ${DEPEND}"
@@ -42,7 +47,7 @@ src_configure() {
-DBUILD_TRANSLATIONS=ON
-DWITH_XTEST=ON
-DWITH_DPMS="$(usex dpms)"
- -DWITH_XINERAMA="$(usex xinerama)"
+ -DWITH_XINERAMA=ON
-DWITH_XCB="$(usex xcb)"
-DWITH_GSTREAMER="$(usex gstreamer)"
-DWITH_OGGVORBIS="$(usex vorbis)"