summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbarcode
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbarcode')
-rw-r--r--trinity-apps/kbarcode/Manifest1
-rw-r--r--trinity-apps/kbarcode/kbarcode-14.1.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/Manifest b/trinity-apps/kbarcode/Manifest
index 440d8daf..9c946f60 100644
--- a/trinity-apps/kbarcode/Manifest
+++ b/trinity-apps/kbarcode/Manifest
@@ -1 +1,2 @@
DIST kbarcode-trinity-14.1.1.tar.xz 276204 BLAKE2B 38fffe75bbc84d98386a9c9b4c92c92fc7108aad8f7045611484bebce40d2d4ad972372863e6d3732575cff9bf5d03e927ab349696a8fa89ada2b8080d3c4f51 SHA512 60f8d01716a8d82f9215a62ea007ef69608264f7767d3f7b7dd7acbbf0aded0ad661687689d82a3527e67554ad565fb2eef4ee2be875eccab8cbe7674d65eeee
+DIST kbarcode-trinity-14.1.2.tar.xz 272980 BLAKE2B a16d247ce63e01df1bba67688e91400e036ab073a676873f86bdaa5202379db9c06f27b58ef68e266cdd9c083c1c9d1956258958aa644b4f6226854c4e66f035 SHA512 1a94c9ddd796dbdf3206b3df88fb8351cbf2643f947ff8d4ba5ba173e0986109599e6f6827f436d15d2fa0e323d5a22c7827e7afa6d3036b5f9a7cd0f718cf8d
diff --git a/trinity-apps/kbarcode/kbarcode-14.1.2.ebuild b/trinity-apps/kbarcode/kbarcode-14.1.2.ebuild
new file mode 100644
index 00000000..53552f9e
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-14.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+IUSE="javascript native-gnu-barcode"
+
+RDEPEND="
+ app-text/barcode
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native-gnu-barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}