summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbarcode
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbarcode')
-rw-r--r--trinity-apps/kbarcode/Manifest1
-rw-r--r--trinity-apps/kbarcode/kbarcode-14.0.11.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/Manifest b/trinity-apps/kbarcode/Manifest
index cb448cb3..72e3b837 100644
--- a/trinity-apps/kbarcode/Manifest
+++ b/trinity-apps/kbarcode/Manifest
@@ -1 +1,2 @@
+DIST kbarcode-trinity-14.0.11.tar.xz 273692 BLAKE2B 3d2f4bd6dbddf3ec1d26323aa84c0362e12be74715443900c6b9f59990d8a8859eb1563540c7aadb1f97a73bca081c68d5d6d9d6150ec670a2c2c7df62cd232b SHA512 8354bf4085bea629171628ce450cfba3d95d47ee39118ad7ed89535be35e3d89ae27cfb1cd70917d269c2e157b3abb31046e6eb63ba6c7442124bd6a3af2c03f
DIST kbarcode-trinity-14.0.8.tar.xz 293940 BLAKE2B 8882da3a4a6ef93b02c9122e3e7ed2a1158b10ada9287177a91318890fb65b9cded53cd8788e7c00299576011b43fbe9cd02d0178a5c3d3f23307e104d4a6490 SHA512 32b8631c6bc1150c335fb142b2c39483fcb7c5df08ee48cea4a5e3f6ac085a24eaed5b93b8e2812d7167f0130ce5fe48fe50df3f21ee164c7b5821bbf3ea64ad
diff --git a/trinity-apps/kbarcode/kbarcode-14.0.11.ebuild b/trinity-apps/kbarcode/kbarcode-14.0.11.ebuild
new file mode 100644
index 00000000..e9a80967
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-14.0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+IUSE="javascript native-gnu-barcode"
+
+RDEPEND="
+ app-text/barcode
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native-gnu-barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}