summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbfx
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbfx')
-rw-r--r--trinity-apps/kbfx/Manifest1
-rw-r--r--trinity-apps/kbfx/kbfx-14.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kbfx/Manifest b/trinity-apps/kbfx/Manifest
index 17682728..47ae5f1b 100644
--- a/trinity-apps/kbfx/Manifest
+++ b/trinity-apps/kbfx/Manifest
@@ -1 +1,2 @@
DIST kbfx-trinity-14.1.0.tar.xz 2386036 BLAKE2B 2e0df3ff24966f60d364c58ebd134d92ab4996e808b201375d2c4acb8ff9ad0fae2a89124a69631c2fe2a722750cef142ac7c778f56828e8a1026fa4797f2276 SHA512 7b97c6b0f92556e6c27107560c9005b0b751326c0567cc77c45b1166a483bd91c06ef579d227e0a009f0283e7262278a078283acb7a83713137b0ceee132a985
+DIST kbfx-trinity-14.1.1.tar.xz 2385680 BLAKE2B 73c6f66eb9fa94e43ae65378d81c303cc4c31ff32be53007c9444808e180f78b73430398656e44068be3bb2df2e5b36c0efba39312bef9dbd5a9b7bcbf26518d SHA512 52c487513180c43da8f79e46046a83e6b7a3448534ae16d01fb85dce37c7028081cbf21f31aad01d5edc10730c0b85dc5e6991ff02aec4a1fc846a664fb2b83a
diff --git a/trinity-apps/kbfx/kbfx-14.1.1.ebuild b/trinity-apps/kbfx/kbfx-14.1.1.ebuild
new file mode 100644
index 00000000..ec031183
--- /dev/null
+++ b/trinity-apps/kbfx/kbfx-14.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bg de hu it nl"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="An alternative to the TDE-Menu"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}