summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kchart/kchart-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kchart/kchart-9999.ebuild')
-rw-r--r--trinity-apps/kchart/kchart-9999.ebuild27
1 files changed, 22 insertions, 5 deletions
diff --git a/trinity-apps/kchart/kchart-9999.ebuild b/trinity-apps/kchart/kchart-9999.ebuild
index 5d3eb31a..3ca1db17 100644
--- a/trinity-apps/kchart/kchart-9999.ebuild
+++ b/trinity-apps/kchart/kchart-9999.ebuild
@@ -1,5 +1,5 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -7,7 +7,7 @@ EAPI="8"
TRINITY_MODULE_NAME="koffice"
TRINITY_BUILD_ADMIN="yes"
TRINITY_SUBMODULE="kchart filters/kchart"
-TSM_EXTRACT_ALSO="lib interfaces filters/libdialogfilter"
+TSM_EXTRACT_ALSO="lib interfaces filters/libdialogfilter doc"
inherit trinity-meta-2
@@ -18,13 +18,15 @@ SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
+IUSE="+handbook"
DEPEND="~trinity-base/tdelibs-${PV}
~trinity-apps/koffice-libs-${PV}
"
-RDEPEND="$DEPEND"
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
KMCOPYLIB="libkformula lib/kformula
libkofficecore lib/kofficecore
@@ -62,6 +64,9 @@ src_prepare() {
libname=""
fi
done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
echo "SUBDIRS=$dirlist" > ${S}/lib/Makefile.am
trinity-meta-2_src_prepare
@@ -79,5 +84,17 @@ src_compile() {
pushd filters/libdialogfilter
emake
popd
+ if use handbook ; then
+ TRINITY_SUBMODULE+=" doc"
+ fi
trinity-meta-2_src_compile
}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}