summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kexi/kexi-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kexi/kexi-9999.ebuild')
-rw-r--r--trinity-apps/kexi/kexi-9999.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/trinity-apps/kexi/kexi-9999.ebuild b/trinity-apps/kexi/kexi-9999.ebuild
index f3d3ce71..00cc89c8 100644
--- a/trinity-apps/kexi/kexi-9999.ebuild
+++ b/trinity-apps/kexi/kexi-9999.ebuild
@@ -1,5 +1,5 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -8,7 +8,7 @@ TRINITY_MODULE_NAME="koffice"
TRINITY_MODULE_TYPE="applications/office"
TRINITY_BUILD_ADMIN="yes"
TRINITY_SUBMODULE="kexi"
-TSM_EXTRACT_ALSO="lib interfaces"
+TSM_EXTRACT_ALSO="lib interfaces doc"
inherit flag-o-matic trinity-meta-2
@@ -19,7 +19,7 @@ SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
-IUSE="mariadb mysql postgres"
+IUSE="+handbook mariadb mysql postgres"
REQUIRED_USE="mysql? ( !mariadb )"
@@ -30,7 +30,9 @@ DEPEND="~trinity-base/tdelibs-${PV}
mariadb? ( dev-db/mariadb-connector-c:= )
postgres? ( dev-libs/libpqxx )"
-RDEPEND="$DEPEND"
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
KMCOPYLIB="
libkformula lib/kformula
@@ -67,6 +69,9 @@ src_prepare() {
libname=""
fi
done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
echo "SUBDIRS=$dirlist kross" > ${S}/lib/Makefile.am
@@ -103,3 +108,12 @@ src_configure() {
fi
trinity-econf ${myconf[@]}
}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}