summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kformula
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kformula')
-rw-r--r--trinity-apps/kformula/Manifest1
-rw-r--r--trinity-apps/kformula/kformula-14.1.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/trinity-apps/kformula/Manifest b/trinity-apps/kformula/Manifest
index f19391fd..46acfcc0 100644
--- a/trinity-apps/kformula/Manifest
+++ b/trinity-apps/kformula/Manifest
@@ -1 +1,2 @@
DIST koffice-trinity-14.0.13.tar.xz 49541404 BLAKE2B 4501137b87772d2e81f251b3f384cfb5417cdb3507786e392a9fe4e98c18806b9749766e51430702432e33773b379184a48f4790c54d17d86b8b6f191b208e5f SHA512 b82e23e653ee07fccdbcda74dc2727e5e0a4cf889794c1319c6985d2133b63e7f92b84dc5fc1727bfc1217bd39c149db66dd2b2fc1762e415e54933561103fe9
+DIST koffice-trinity-14.1.0.tar.xz 49531604 BLAKE2B 1aa5e3b49bdcac1ec7c52f370194d26413409e04db97ab96c8286a4180a37d89b125d083f269c06ab2bdcaadbdc62767da6d70ece8915b57fe5d5c0baed0cca0 SHA512 4dde81ecb3071e07064ffa31aadfcca6755e478904fc66e69f2c914180b65d978cd807b4761073c484c7ddd8f1f81cb312a96d8dfb3d81a5f069db27885a217f
diff --git a/trinity-apps/kformula/kformula-14.1.0.ebuild b/trinity-apps/kformula/kformula-14.1.0.ebuild
new file mode 100644
index 00000000..3d143231
--- /dev/null
+++ b/trinity-apps/kformula/kformula-14.1.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="kformula filters/kformula"
+TSM_EXTRACT_ALSO="lib interfaces doc"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="KOffice formula editor for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+handbook"
+
+DEPEND="~trinity-apps/koffice-libs-${PV}
+ ~trinity-base/kcontrol-${PV}"
+
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+src_prepare() {
+ local search_path="${TDEDIR}/${get_libdir}"
+ local libname dirname dirlist x
+ libname=""
+ for x in $KMCOPYLIB; do
+ if [ "${libname}" == "" ] ; then
+ libname="${x}"
+ else
+ dirname=$x
+ mkdir -p ${dirname}
+ pushd ${dirname}
+ if [ ! "$(find ${search_path} -maxdepth 1 -name ${libname}*) 2>/dev/null" == "" ]; then
+ ln -s ${TDEDIR}/$(get_libdir)/${libname}* .
+ dirlist="${dirlist} ${dirname/lib\/}"
+ fi
+ popd
+ libname=""
+ fi
+ done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+ echo "SUBDIRS=$dirlis" > "${S}/lib/Makefile.am"
+ echo "SUBDIRS= kformula" > "${S}/filters/Makefile.am"
+ trinity-meta-2_src_prepare
+
+ echo 'all:' > "${S}/Makefile.am"
+ echo 'install:' >> "${S}/Makefile.am"
+ echo '.PHONY: all' >> "${S}/Makefile.am"
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}