summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kima
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kima')
-rw-r--r--trinity-apps/kima/Manifest1
-rw-r--r--trinity-apps/kima/kima-14.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/kima/Manifest b/trinity-apps/kima/Manifest
index 5c538d58..6c53fa25 100644
--- a/trinity-apps/kima/Manifest
+++ b/trinity-apps/kima/Manifest
@@ -1 +1,2 @@
DIST kima-trinity-14.1.0.tar.xz 44300 BLAKE2B cc4204113367fea2539afea4531dbcddc9b04452a1c6713e1a129e0c3245c60160c860c003d32b1c1fa93f21e1e2821f32b6b44aae00459eeaffa69a43d27199 SHA512 f519b6828c22a8e817937205d139bb1ee1e0d2b2c0386d360a8271bfcea2f75a7ed8568665f5808ce16c4b74dad400bfc009883ec54be80b8fa5a3e1a9b87352
+DIST kima-trinity-14.1.1.tar.xz 44016 BLAKE2B be20af01d144451a4df8c09be0c54cae490edb6f99e7384becf08881287cf9ad8ee3d1c577b0da3050c885823a5f76232fe4bbd13a4513829876bc279a96a268 SHA512 5e6a803a700b0e5ed9a3892a3d6558014cd8824bc96c5e011a2ec2b0f05dae78a638d5386e0d998609fad3cd43d4caa5a2207e9a2d8352f1f09d94b5d89aea54
diff --git a/trinity-apps/kima/kima-14.1.1.ebuild b/trinity-apps/kima/kima-14.1.1.ebuild
new file mode 100644
index 00000000..3252a2e6
--- /dev/null
+++ b/trinity-apps/kima/kima-14.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es et hu id nl sv tr"
+TRINITY_MODULE_TYPE="applications/settings"
+inherit trinity-base-2
+
+DESCRIPTION="A Kicker monitoring applet"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+# NVControl support needs the nvidia-settings package,
+# which isn't in the Portage tree anymore. So if there
+# is interest, it could be imported to the overlay maybe.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NVCONTROL=OFF
+ )
+
+ trinity-base-2_src_configure
+}