summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/koffice-i18n')
-rw-r--r--trinity-apps/koffice-i18n/Manifest1
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-14.1.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/trinity-apps/koffice-i18n/Manifest b/trinity-apps/koffice-i18n/Manifest
index 3e745182..0fac1d60 100644
--- a/trinity-apps/koffice-i18n/Manifest
+++ b/trinity-apps/koffice-i18n/Manifest
@@ -1 +1,2 @@
DIST koffice-i18n-trinity-14.1.1.tar.xz 43809980 BLAKE2B 3bc35488b7872de9413bbdad7ab515248e2097b57c1ffd00d9cc7e1e0b91c1a47fc0c48a6d92af9d2845d1c54473525755cb01b334862122cd5285ec9dd5e89d SHA512 6568b9bf3cde7f475a7758a91a0055effd02321163284515a5ddd1ae66779020bc79b949fc6942cc6bb8dcf79cd800123981bc49dda72a833328c9f8c35cc33b
+DIST koffice-i18n-trinity-14.1.2.tar.xz 43808312 BLAKE2B ec6eff0cffeac7019565235133961d912634bf58795b77aeac3872bcc8b2a4ac891627e392be7139c27b5a3061f0045c7ced3972efcf46144eff214e8c21951f SHA512 89a2ea262956db73e48c27bc6ad557a0e7f52297ecba17817c388bd10c6299db37b50f47a582bf38e2e6e1708f0afaef1a0d72fd8e6d49aea9124a27d4534a90
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-14.1.2.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-14.1.2.ebuild
new file mode 100644
index 00000000..69fc7ae5
--- /dev/null
+++ b/trinity-apps/koffice-i18n/koffice-i18n-14.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2021-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/office"
+
+inherit trinity-base-2
+
+DESCRIPTION="TDE internationalization package for Koffice [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+TRINITY_LANGS="bg ca cs cy da de el en_GB es et eu fa fi
+ fr ga gl hu it ja km lv ms nb nds ne nl pl pt pt_BR
+ ru sk sl sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="${DEPEND}"
+
+LINGUAS="en"
+
+find_lang() {
+ local lang
+ lang=${1}
+ LINGUAS+=" ${lang}"
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do find_lang
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ [[ "${LINGUAS}" == "en" ]] && return 0
+ trinity-base-2_src_install
+}