summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kplato
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kplato')
-rw-r--r--trinity-apps/kplato/Manifest1
-rw-r--r--trinity-apps/kplato/kplato-14.1.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/trinity-apps/kplato/Manifest b/trinity-apps/kplato/Manifest
index 0a8d1506..ea5d25c0 100644
--- a/trinity-apps/kplato/Manifest
+++ b/trinity-apps/kplato/Manifest
@@ -1 +1,2 @@
DIST koffice-trinity-14.1.0.tar.xz 49531604 BLAKE2B 1aa5e3b49bdcac1ec7c52f370194d26413409e04db97ab96c8286a4180a37d89b125d083f269c06ab2bdcaadbdc62767da6d70ece8915b57fe5d5c0baed0cca0 SHA512 4dde81ecb3071e07064ffa31aadfcca6755e478904fc66e69f2c914180b65d978cd807b4761073c484c7ddd8f1f81cb312a96d8dfb3d81a5f069db27885a217f
+DIST koffice-trinity-14.1.1.tar.xz 49531852 BLAKE2B b63fdcab90416262a70b74fa76e6f4548e82cb7c5c55eb8a1d97fd705b5d021d9af64b9502b3f109bc031dc6ac45330ce5885e861363a8ce1ce59fc320eabae6 SHA512 0e251cdc038bb34d9083d29704ef8b0afab870aed485a4aca1076ba0ed8288cf627d9d24ea898ea9be7b8570c2825e3af6a48c01de32bbccf169ddded83608f2
diff --git a/trinity-apps/kplato/kplato-14.1.1.ebuild b/trinity-apps/kplato/kplato-14.1.1.ebuild
new file mode 100644
index 00000000..079a32e3
--- /dev/null
+++ b/trinity-apps/kplato/kplato-14.1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="kdgantt kplato"
+TSM_EXTRACT_ALSO="lib kugar interfaces doc"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="KPlato is a project management application for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+handbook"
+
+DEPEND="~trinity-apps/koffice-libs-${PV}
+"
+
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )
+"
+
+KMCOPYLIB="libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkstore lib/store"
+
+src_prepare() {
+ local search_path="${TDEDIR}/${get_libdir}"
+ local libname dirname dirlist x
+ libname=""
+ for x in $KMCOPYLIB; do
+ if [ "${libname}" == "" ] ; then
+ libname="${x}"
+ else
+ dirname=$x
+ mkdir -p ${dirname}
+ pushd ${dirname}
+ if [ ! "$(find ${search_path} -maxdepth 1 -name ${libname}*) 2>/dev/null" == "" ]; then
+ ln -s ${TDEDIR}/$(get_libdir)/${libname}* .
+ dirlist="${dirlist} ${dirname/lib\/}"
+ fi
+ popd
+ libname=""
+ fi
+ done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+
+ echo "SUBDIRS=$dirlist" > "${S}/lib/Makefile.am"
+ trinity-meta-2_src_prepare
+
+ echo 'all:' > "${S}/Makefile.am"
+ echo 'install:' >> "${S}/Makefile.am"
+ echo '.PHONY: all' >> "${S}/Makefile.am"
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}