summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kplato
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kplato')
-rw-r--r--trinity-apps/kplato/Manifest1
-rw-r--r--trinity-apps/kplato/kplato-14.0.13.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/trinity-apps/kplato/Manifest b/trinity-apps/kplato/Manifest
index 73586ed3..3643962a 100644
--- a/trinity-apps/kplato/Manifest
+++ b/trinity-apps/kplato/Manifest
@@ -1 +1,2 @@
DIST koffice-trinity-14.0.12.tar.xz 49536824 BLAKE2B 2bece83ab01797fab8d375df7b20b2768da70f9c3441058f457947f3f0569a337fe143d786ce266b27ea093f08f2e1a7d3ce23e4310ecc5126bac2620c1da439 SHA512 4b657747a004a01941845d25f886db66cf89cdb754a3213b17a9fad0e3ec1e9d90dafdc670f31cf6bdd900e3ca50b68cdb8c9b54a5332585d50b3b1cbe8cffea
+DIST koffice-trinity-14.0.13.tar.xz 49541404 BLAKE2B 4501137b87772d2e81f251b3f384cfb5417cdb3507786e392a9fe4e98c18806b9749766e51430702432e33773b379184a48f4790c54d17d86b8b6f191b208e5f SHA512 b82e23e653ee07fccdbcda74dc2727e5e0a4cf889794c1319c6985d2133b63e7f92b84dc5fc1727bfc1217bd39c149db66dd2b2fc1762e415e54933561103fe9
diff --git a/trinity-apps/kplato/kplato-14.0.13.ebuild b/trinity-apps/kplato/kplato-14.0.13.ebuild
new file mode 100644
index 00000000..66e10d45
--- /dev/null
+++ b/trinity-apps/kplato/kplato-14.0.13.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="kdgantt kplato"
+TSM_EXTRACT_ALSO="lib kugar interfaces doc"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="KPlato is a project management application for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+handbook"
+
+DEPEND="~trinity-apps/koffice-libs-${PV}
+"
+
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )
+"
+
+KMCOPYLIB="libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkstore lib/store"
+
+src_prepare() {
+ local search_path="${TDEDIR}/${get_libdir}"
+ local libname dirname dirlist x
+ libname=""
+ for x in $KMCOPYLIB; do
+ if [ "${libname}" == "" ] ; then
+ libname="${x}"
+ else
+ dirname=$x
+ mkdir -p ${dirname}
+ pushd ${dirname}
+ if [ ! "$(find ${search_path} -maxdepth 1 -name ${libname}*) 2>/dev/null" == "" ]; then
+ ln -s ${TDEDIR}/$(get_libdir)/${libname}* .
+ dirlist="${dirlist} ${dirname/lib\/}"
+ fi
+ popd
+ libname=""
+ fi
+ done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+
+ echo "SUBDIRS=$dirlist" > ${S}/lib/Makefile.am
+ trinity-meta-2_src_prepare
+
+ echo 'all:' > ${S}/Makefile.am
+ echo 'install:' >> ${S}/Makefile.am
+ echo '.PHONY: all' >> ${S}/Makefile.am
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}