summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kplayer
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kplayer')
-rw-r--r--trinity-apps/kplayer/Manifest1
-rw-r--r--trinity-apps/kplayer/kplayer-14.1.0.ebuild36
-rw-r--r--trinity-apps/kplayer/kplayer-9999.ebuild2
3 files changed, 38 insertions, 1 deletions
diff --git a/trinity-apps/kplayer/Manifest b/trinity-apps/kplayer/Manifest
new file mode 100644
index 00000000..8f8c8db7
--- /dev/null
+++ b/trinity-apps/kplayer/Manifest
@@ -0,0 +1 @@
+DIST kplayer-trinity-14.1.0.tar.xz 3929400 BLAKE2B 51f14a15d847f28faeb5d2f7dfd2025ee9ad88782b525a43ba91cf17bc9cc7947dd2832a1151939e0a3e95d19fc8dc7fd67246e7e1da1faf70ec1107d287da3e SHA512 3c7f8126d13ba57d01ce11ae2774b48baa603ff5b0744ae8a61e1d67818db502f3137d50f901bad57c916e9776f61c38c2f366d48847626159761b24526fcb03
diff --git a/trinity-apps/kplayer/kplayer-14.1.0.ebuild b/trinity-apps/kplayer/kplayer-14.1.0.ebuild
new file mode 100644
index 00000000..43096782
--- /dev/null
+++ b/trinity-apps/kplayer/kplayer-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="be br ca cs cy da de el en_GB es et fi
+ fr ga gl he hu it ja nb nl pa pl pt
+ pt_BR ru sr sr@Latn sv tr zh_CN"
+
+TRINITY_DOC_LANGS="da es it pt sv"
+
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="KPlayer is a TDE media player based on mplayer."
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="media-video/mplayer"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kplayer/kplayer-9999.ebuild b/trinity-apps/kplayer/kplayer-9999.ebuild
index d6e6b68b..1216a4e3 100644
--- a/trinity-apps/kplayer/kplayer-9999.ebuild
+++ b/trinity-apps/kplayer/kplayer-9999.ebuild
@@ -13,7 +13,7 @@ TRINITY_LANGS="be br ca cs cy da de el en_GB es et fi
TRINITY_DOC_LANGS="da es it pt sv"
-TRINITY_MODULE_TYPE="applications"
+TRINITY_MODULE_TYPE="applications/multimedia"
inherit trinity-base-2
DESCRIPTION="KPlayer is a TDE media player based on mplayer."