summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kugar/kugar-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kugar/kugar-9999.ebuild')
-rw-r--r--trinity-apps/kugar/kugar-9999.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/trinity-apps/kugar/kugar-9999.ebuild b/trinity-apps/kugar/kugar-9999.ebuild
index e55bbf25..63a41cc1 100644
--- a/trinity-apps/kugar/kugar-9999.ebuild
+++ b/trinity-apps/kugar/kugar-9999.ebuild
@@ -1,5 +1,5 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -8,7 +8,7 @@ TRINITY_MODULE_NAME="koffice"
TRINITY_MODULE_TYPE="applications/office"
TRINITY_BUILD_ADMIN="yes"
TRINITY_SUBMODULE="kugar filters/kugar"
-TSM_EXTRACT_ALSO="lib interfaces"
+TSM_EXTRACT_ALSO="lib interfaces doc"
inherit flag-o-matic trinity-meta-2
@@ -19,13 +19,15 @@ SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
+IUSE="+handbook"
DEPEND="
~trinity-apps/koffice-libs-${PV}
"
-RDEPEND="$DEPEND"
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
KMCOPYLIB="
libkformula lib/kformula
@@ -57,6 +59,9 @@ src_prepare() {
libname=""
fi
done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
echo "SUBDIRS=$dirlist" > ${S}/lib/Makefile.am
echo "SUBDIRS= kugar" > ${S}/filters/Makefile.am
@@ -72,3 +77,12 @@ src_configure() {
append-cxxflags "-std=c++11"
trinity-meta-2_src_configure
}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}