summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mplayerthumbs
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mplayerthumbs')
-rw-r--r--trinity-apps/mplayerthumbs/Manifest1
-rw-r--r--trinity-apps/mplayerthumbs/mplayerthumbs-14.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/mplayerthumbs/Manifest b/trinity-apps/mplayerthumbs/Manifest
index ebe0b137..b21e11a5 100644
--- a/trinity-apps/mplayerthumbs/Manifest
+++ b/trinity-apps/mplayerthumbs/Manifest
@@ -1 +1,2 @@
DIST mplayerthumbs-trinity-14.0.13.tar.xz 26604 BLAKE2B ff29042d27759f38d8ff41724e7b84fa21949db07aa86338281fced519e8c382ba7e7597c200d16112c5471fd0f2acbdb39cb6d5a11d91480a845b56dc955893 SHA512 f767a93baebdf75ef903f250631552925cfba43f40bdb01e52b51d46f8e7e5680f2990305e3acbedba634b6d8f321f1a54d401ead6f50f7baa71f1743357ef6c
+DIST mplayerthumbs-trinity-14.1.0.tar.xz 26596 BLAKE2B c8d899bf33b11a7b5db3da8600dfa9467499e4cc02b0cc37ca45b8781d7eac7f173df04b548941d1aca73e4dc2cc3a3d4bf0db6cbd883bcd997418b3e11f503a SHA512 bb642d7d827ad46da06e4d43d19fa94423dc7056a8c79b8493f31b72b617ca360b6766dbbfca8533738c53fba10cbc41496a1cba6b787f44cf3ad9b7c8e10038
diff --git a/trinity-apps/mplayerthumbs/mplayerthumbs-14.1.0.ebuild b/trinity-apps/mplayerthumbs/mplayerthumbs-14.1.0.ebuild
new file mode 100644
index 00000000..2b366a15
--- /dev/null
+++ b/trinity-apps/mplayerthumbs/mplayerthumbs-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="MPlayer based thumbnail generator for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+strips"
+
+RDEPEND="media-video/mplayer"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_STRIPS_SUPPORT="$(usex strips)"
+ )
+
+ trinity-base-2_src_configure
+}