summaryrefslogtreecommitdiffstats
path: root/trinity-apps/smartcardauth
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/smartcardauth')
-rw-r--r--trinity-apps/smartcardauth/Manifest2
-rw-r--r--trinity-apps/smartcardauth/smartcardauth-14.0.8.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/trinity-apps/smartcardauth/Manifest b/trinity-apps/smartcardauth/Manifest
new file mode 100644
index 00000000..5a3967fa
--- /dev/null
+++ b/trinity-apps/smartcardauth/Manifest
@@ -0,0 +1,2 @@
+DIST smartcardauth-trinity-14.0.7.tar.xz 294180 BLAKE2B d8cbb8619a595db08e3d110d4135805a2819935225f85f6243e72de56efed136a8c75d6cc2b30e9e772b98ae4cde9d02ee35cbf474982c01a15b86221977bf39 SHA512 3bec0e3589030fe926704ca22bb8fc71e934a062a8df3c9d2cae7bbea4740d7e89686da08992b9631e0ccce195f5cd0ef39f87019e8445807f55d319c3c42f10
+DIST smartcardauth-trinity-14.0.8.tar.xz 295808 BLAKE2B ca3e19678cd0dc52864d4eb3009c88c7faee7c00a22b023b521820dca6666087b262786d47ecf0edb425e57f4b511c58c9ce932e0368dc4687896214c65f996c SHA512 3c57ac9ca901a8aab747e5c9bf75bbc3eb0ee5830bfef3f2871ce77d33b63159ab4ee4679d15beaf8cca7470558179d33f0d9cbae2dd0ecf287cfc5730efb9f7
diff --git a/trinity-apps/smartcardauth/smartcardauth-14.0.8.ebuild b/trinity-apps/smartcardauth/smartcardauth-14.0.8.ebuild
new file mode 100644
index 00000000..93d3efca
--- /dev/null
+++ b/trinity-apps/smartcardauth/smartcardauth-14.0.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+inherit trinity-base-2
+
+DESCRIPTION="SmartCard login and LUKS decrypt"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" libressl"
+
+DEPEND+="
+ net-libs/gnutls
+ dev-libs/pkcs11-helper
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+"
+RDEPEND+=" ${DEPEND}"