summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest1
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
index ea583262..ebf57a6c 100644
--- a/trinity-apps/tdeio-sword/Manifest
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -1 +1,2 @@
DIST tdeio-sword-trinity-14.1.1.tar.xz 102700 BLAKE2B 51d9aa3b77665cc60f10812dc413cdd815f888af626d9b536df01b78e82bae1266694a341b5445cebe055ccb31b212472fe5fdc545e47caaf7a8224b27b0193e SHA512 962cd0c87c7f757ee14c01a0e09a410beec73576430b9f7cb1a06b9481310b0923db4617d9909a7728ffea504d869509ea40f5badb26382d6fedfb76117e0b79
+DIST tdeio-sword-trinity-14.1.2.tar.xz 101240 BLAKE2B fbd4fe56279a21a8c93189aac23314a03bdf0582a0201194d41a4de183cc45156d937f75bb6df7716ee6bfe16032ef5779bdfede11e8a58b6cd353a6394bd11c SHA512 c91de1426f572ff497f131adf8d9d16dfc2ea317db3a4afea85ebeb5971aaad02e7b57419f3912a0a958f37165e49906ee2973d5231512223e1b94e89b0ff86c
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.1.2.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.1.2.ebuild
new file mode 100644
index 00000000..60c9ba9a
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="app-text/sword"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}