summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest1
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
index 32af06e7..3b4c9072 100644
--- a/trinity-apps/tdeio-sword/Manifest
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -1 +1,2 @@
DIST tdeio-sword-trinity-14.0.13.tar.xz 102732 BLAKE2B 4ef76aacec5187a0d4f6d881bf230e08d03579dee8868572d948319220473e84e18bf5fd5f4ccf06b1d7c08a24c2f95450e99c761974fcd42390ab4ec3db326c SHA512 87ad334efc7d2261bb887e0bb273c683ea591988d65551968647902b02c33b36250487d2cc8bb5e0490dde0785dc12c6bc2e8018d7c4f75292b8b36ec3c305a4
+DIST tdeio-sword-trinity-14.1.0.tar.xz 102716 BLAKE2B d42fd61a4e3a9331c169546a3ea4718e4eafdb5c2b8e11474985b022ec333d07edf521a0eb5875c8f54de405cbcf145eb9b7966598eb8608c6e0144c749cca3e SHA512 edc87933296bf7905acc86f69dfe9b241420f8cb858173de279e3454369d548170471d103e9de0182d944d0ffbafcf4eea8a27a5fd7ad6705f296912916b2269
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.1.0.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.1.0.ebuild
new file mode 100644
index 00000000..502a5559
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="app-text/sword"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}