summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest1
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.0.11.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
index ad21e7b9..2a1ac1e0 100644
--- a/trinity-apps/tdeio-sword/Manifest
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -1 +1,2 @@
+DIST tdeio-sword-trinity-14.0.11.tar.xz 102640 BLAKE2B 0f92305fc50244a04bba50adbef508c846ccefafb9b283978ab583aa31edaa3d3aa32c2f501ed24f8f362a51d29272ed236428539bf860b168d43963ffebb075 SHA512 e8e4c6bd83353123a45fd46fe0eccbc7fa4eb8d8b7d1a5a0c39ba64fb7aeb088205e949cfb245cb326026959665504879256ffc9f45b85ba1bad054455bd5d35
DIST tdeio-sword-trinity-14.0.8.tar.xz 375116 BLAKE2B 8e4ba3d765c97a592f9d648165f0bece5c6756214148a0305f063d97b06b85aa7bb19d8f19e94b69300e130b552f170943e3be163ff49829049973e82fed01c5 SHA512 06cc2fa173a9a3e0a9c584f2712aa57f8c5fcc5d7135b4f283f375fdd8f5205685d8a84f90879797035b876eaf82abea8a83317b286f21d16d8a30138218c7a3
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.0.11.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.0.11.ebuild
new file mode 100644
index 00000000..16db221c
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.0.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="app-text/sword"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}