summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn/tdesvn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdesvn/tdesvn-9999.ebuild')
-rw-r--r--trinity-apps/tdesvn/tdesvn-9999.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/trinity-apps/tdesvn/tdesvn-9999.ebuild b/trinity-apps/tdesvn/tdesvn-9999.ebuild
index 4af2cc77..35df355b 100644
--- a/trinity-apps/tdesvn/tdesvn-9999.ebuild
+++ b/trinity-apps/tdesvn/tdesvn-9999.ebuild
@@ -4,32 +4,28 @@
EAPI="7"
-TRINITY_MODULE_TYPE="applications"
-
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+TRINITY_MODULE_TYPE="applications"
inherit trinity-base-2
DESCRIPTION="Subversion client with tight TDE integration"
HOMEPAGE="https://trinitydesktop.org/"
-need-trinity
-
LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="${TRINITY_VER}"
+SLOT="14"
+IUSE="test"
-IUSE+=" test"
RESTRICT+=" !test? ( test )"
-DEPEND+=" dev-vcs/subversion"
-RDEPEND+=" ${DEPEND}"
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DBUILD_TESTS="$(usex test)"
)
-
trinity-base-2_src_configure
}