summaryrefslogtreecommitdiffstats
path: root/trinity-apps/twin-style-suse2
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/twin-style-suse2')
-rw-r--r--trinity-apps/twin-style-suse2/Manifest1
-rw-r--r--trinity-apps/twin-style-suse2/twin-style-suse2-14.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/twin-style-suse2/Manifest b/trinity-apps/twin-style-suse2/Manifest
index 003a1327..a1d2fbbf 100644
--- a/trinity-apps/twin-style-suse2/Manifest
+++ b/trinity-apps/twin-style-suse2/Manifest
@@ -1 +1,2 @@
DIST twin-style-suse2-trinity-14.1.0.tar.xz 77744 BLAKE2B 7b885ffcca538c80c5750fc5a1239531d0cc9a510d249347050b6fdb8bc8cfcd381edbcf8527506ac6018da430d0de2a7675575570a47db20a50af56116f2357 SHA512 226e2fd37bd934e0879d62fc1de41f85836faa41d4da5f93a323a5c4983115d8fda09ea642c5c9ccf872ad9d30d36daa7d5837031dc2adc49010b5eb7964915c
+DIST twin-style-suse2-trinity-14.1.1.tar.xz 77748 BLAKE2B 4f87e73da83e474061bdcac504b733ebe5d7eadbef2dce5955822acbf6eed1c2773703000fce7d0c04ba09315989d7f6b562097defd382433442fa8db0fda720 SHA512 35ff15a027c9c18403e4b8e1caacd4aead3385111617bfe83882dfe4626e3cdd1dfed42d49a48fea914b6352d431b90024ef1b073254d7801b65984257cffd32
diff --git a/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.1.ebuild b/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.1.ebuild
new file mode 100644
index 00000000..3a0b470e
--- /dev/null
+++ b/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="bg bs cs cy da de el en_GB en_US es et fi fr
+ he hi hr hu id it ja km ko lo lt nb nl pa pl
+ pt_BR pt ro ru sk sl sr sv ta tr uk zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme from SUSE 9.3/10.0/10.1"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}