summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/kicker-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kicker/kicker-9999.ebuild')
-rw-r--r--trinity-base/kicker/kicker-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/trinity-base/kicker/kicker-9999.ebuild b/trinity-base/kicker/kicker-9999.ebuild
new file mode 100644
index 00000000..cb5dafda
--- /dev/null
+++ b/trinity-base/kicker/kicker-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+KEYWORDS=
+IUSE="xcomposite"
+
+DEPEND=">=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/tdebase-data-${PV}:${SLOT}
+ dev-libs/dbus-tqt
+ xcomposite? ( x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ trinity-base/kmenuedit:${SLOT}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xcomposite XFIXES)
+ $(cmake-utils_use_with xcomposite XRENDER)
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ )
+
+ trinity-meta_src_configure
+}