summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmilo
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kmilo')
-rw-r--r--trinity-base/kmilo/files/tdeutils-strlcpy.patch19
-rw-r--r--trinity-base/kmilo/kmilo-14.1.1.ebuild5
2 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/kmilo/files/tdeutils-strlcpy.patch b/trinity-base/kmilo/files/tdeutils-strlcpy.patch
new file mode 100644
index 00000000..997a4010
--- /dev/null
+++ b/trinity-base/kmilo/files/tdeutils-strlcpy.patch
@@ -0,0 +1,19 @@
+--- a/ConfigureChecks.cmake 2023-11-20 07:43:31.808978636 +0300
++++ b/ConfigureChecks.cmake 2023-11-20 07:47:59.756967430 +0300
+@@ -28,13 +28,9 @@
+ tde_setup_gcc_visibility( )
+ endif( )
+
+-
+-##### ark #######################################
+-
+-if( BUILD_ARK )
+- check_symbol_exists( strlcpy string.h HAVE_STRLCPY_PROTO )
+- check_symbol_exists( strlcat string.h HAVE_STRLCAT_PROTO )
+-endif( BUILD_ARK )
++# strlcat and strlcpy check
++check_symbol_exists( strlcpy string.h HAVE_STRLCPY_PROTO )
++check_symbol_exists( strlcat string.h HAVE_STRLCAT_PROTO )
+
+
+ ##### kcalc #####################################
diff --git a/trinity-base/kmilo/kmilo-14.1.1.ebuild b/trinity-base/kmilo/kmilo-14.1.1.ebuild
index d2404bef..7b1ef9e6 100644
--- a/trinity-base/kmilo/kmilo-14.1.1.ebuild
+++ b/trinity-base/kmilo/kmilo-14.1.1.ebuild
@@ -19,6 +19,11 @@ DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
RDEPEND="${DEPEND}
lm-sensors? ( sys-apps/lm-sensors )"
+src_prepare() {
+ eapply "${FILESDIR}/tdeutils-strlcpy.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_ASUS="$(usex asus-laptop)"