summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild')
-rw-r--r--trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
new file mode 100644
index 00000000..3bb0a5d0
--- /dev/null
+++ b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-14.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+TSM_EXTRACT="tdeioslave"
+
+DESCRIPTION="Generic Trinity TDEIOslaves"
+KEYWORDS="~amd64 ~x86"
+IUSE="samba ldap sasl openexr +tdehw"
+
+DEPEND="x11-libs/libXcursor
+ net-libs/rpcsvc-proto
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ samba? ( net-fs/samba )
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+RDEPEND="${DEPEND}"
+# CHECKME: optional dependencies
+#DEPEND="
+# >=dev-libs/cyrus-sasl-2
+# x11-apps/xhost
+RDEPEND="${DEPEND}
+ virtual/ssh
+ trinity-base/tdeeject:${SLOT}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_SAMBA="$(usex samba)"
+ -DWITH_LDAP="$(usex ldap)"
+ -DWITH_SASL="$(usex sasl)"
+ -DWITH_OPENEXR="$(usex openexr)"
+ -DWITH_TDEHWLIB="$(usex tdehw)"
+ )
+
+ trinity-meta-2_src_configure
+}