summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdesu/tdesu-14.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tdesu/tdesu-14.1.0.ebuild')
-rw-r--r--trinity-base/tdesu/tdesu-14.1.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/trinity-base/tdesu/tdesu-14.1.0.ebuild b/trinity-base/tdesu/tdesu-14.1.0.ebuild
deleted file mode 100644
index 72a37cf7..00000000
--- a/trinity-base/tdesu/tdesu-14.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Copyright 2020-2023 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-TRINITY_MODULE_NAME="tdebase"
-TRINITY_MODULE_TYPE="core"
-inherit trinity-meta-2
-
-DESCRIPTION="Trinity gui for su(1) or sudo"
-if [[ ${PV} != *9999* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-IUSE="sudo"
-
-DEPEND="sudo? ( app-admin/sudo )"
-RDEPEND="${DEPEND}"
-
-src_configure () {
- local mycmakeargs=(
- -DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
- -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
- )
-
- trinity-meta-2_src_configure
-}
-
-pkg_postinst () {
- if use sudo; then
- einfo "Remember that the sudo use flag sets only the default superuser command."
- einfo "It can be overriden on a user-level by adding:"
- einfo " [super-user-command]"
- einfo " super-user-command=su"
- einfo "to the kdeglobals config file, which is usually"
- einfo "located in the ~/.trinity/share/config/ directory."
- fi
-}