summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD
diff options
context:
space:
mode:
authoralbator <albator@arcadia.vtf>2011-11-14 19:55:09 +0100
committeralbator <albator@arcadia.vtf>2011-11-14 19:55:09 +0100
commit46e357bd6dc004a89fd759221a9b19f13749d348 (patch)
tree7cef3b3655cc9f51450eacba93c198e78d897625 /arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD
parent4f5750cbaf62281fd04eee8511756758d037f7f6 (diff)
parent306a78ba62a0ed385c85ee18a9ebab6a8a3eb50b (diff)
downloadtde-packaging-46e357bd6dc004a89fd759221a9b19f13749d348.tar.gz
tde-packaging-46e357bd6dc004a89fd759221a9b19f13749d348.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD b/arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD
new file mode 100644
index 000000000..88db1ddf7
--- /dev/null
+++ b/arch/3.5.13/trinity-base/trinity-pyqt3/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: David C. Rankin <drankinatty@gmail.com>
+#
+# All modifications and uses of this file are licensed under
+# the software for which this file was made for, should the software
+# be under an Open Source License, at least version 1.9, defined
+# by the Open Source Initiative. In other cases, this file is automatically
+# released to the Public Domain.
+#
+
+pkgname=trinity-pyqt3
+pkgver=3.18.1
+pkgrel=1
+pkgdesc="A set of Python bindings for the Qt3 toolkit"
+arch=('i686' 'x86_64')
+url="http://www.riverbankcomputing.com/software/pyqt/intro"
+groups=('trinity-base')
+depends=('python2-sip' 'qscintilla-qt3' 'trinity-qt3')
+license=('GPL')
+provides=('trinity-pyqt3' 'pyqt3')
+conflicts=('pyqt3')
+replaces=('trinity-pyqt3')
+source=("http://www.riverbankcomputing.com/static/Downloads/PyQt3/PyQt-x11-gpl-${pkgver}.tar.gz")
+md5sums=('f1d120495d1aaf393819e988c0a7bb7e')
+
+build() {
+ cd ${srcdir}/PyQt-x11-gpl-${pkgver}
+
+ . /etc/profile.d/qt3.sh
+
+ export QMAKESPEC="/opt/qt/mkspecs/default"
+
+ echo yes | python2.7 configure.py -q /opt/qt/
+
+ make
+}
+
+package() {
+ cd ${srcdir}/PyQt-x11-gpl-${pkgver}
+ make DESTDIR=${pkgdir} install
+}