summaryrefslogtreecommitdiffstats
path: root/arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-11-15 17:09:41 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-11-15 17:09:41 +0100
commit0d43adafed4ce0fa22988f2ff8948f8f64d811a3 (patch)
treea15c8b9af137b41833b5a51a4da88ea6478d09fa /arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD
parent9ad10a881e3df75b587767eb5cc78b2ea840316a (diff)
downloadtde-packaging-0d43adafed4ce0fa22988f2ff8948f8f64d811a3.tar.gz
tde-packaging-0d43adafed4ce0fa22988f2ff8948f8f64d811a3.zip
ArchLinux: Add powerpc64le to architectures.
Cleanup some unnecessary dependencies. Add pkgbuilds for dependencies that are not available on archlinuxpower.org. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD')
-rw-r--r--arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD b/arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD
new file mode 100644
index 000000000..f429c1492
--- /dev/null
+++ b/arch/tde-deps/gdk-pixbuf-xlib/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+
+pkgname=gdk-pixbuf-xlib
+pkgver=2.40.2
+pkgrel=2
+pkgdesc="Deprecated Xlib integration for GdkPixbuf"
+arch=('powerpc64le')
+url="https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib"
+license=(LGPL2.1)
+depends=(gdk-pixbuf2 libx11)
+makedepends=(gtk-doc git meson)
+options=(debug)
+_commit=c142b818801e0affceea4a2139cf5630a283e54e # tags/2.40.2^0
+source=("git+$url.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ arch-meson $pkgname build -D gtk_doc=true
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ depends+=(libgdk_pixbuf-2.0.so)
+ provides+=(libgdk_pixbuf_xlib-2.0.so)
+
+ meson install -C build --destdir "$pkgdir"
+}
+
+# vim:set sw=2 sts=-1 et: