summaryrefslogtreecommitdiffstats
path: root/dilos/core/tdebindings/debian/patches/dilos.patch
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-15 19:23:30 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-15 19:23:30 +0800
commit0277521b268b21caf0ee21202b92784f302baadc (patch)
tree5d856f96adfbe46b57da31cf60daa1084b4e7a1e /dilos/core/tdebindings/debian/patches/dilos.patch
parenteb16e7c7281e182297581fa8d565561869c81bca (diff)
downloadtde-packaging-0277521b268b21caf0ee21202b92784f302baadc.tar.gz
tde-packaging-0277521b268b21caf0ee21202b92784f302baadc.zip
DEB: adjusted to new 'core' folder for main packages.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'dilos/core/tdebindings/debian/patches/dilos.patch')
-rw-r--r--dilos/core/tdebindings/debian/patches/dilos.patch98
1 files changed, 98 insertions, 0 deletions
diff --git a/dilos/core/tdebindings/debian/patches/dilos.patch b/dilos/core/tdebindings/debian/patches/dilos.patch
new file mode 100644
index 000000000..89ff7e33f
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/dilos.patch
@@ -0,0 +1,98 @@
+Index: tdebindings/korundum/bin/krubyinit.cpp
+===================================================================
+--- tdebindings.orig/korundum/bin/krubyinit.cpp
++++ tdebindings/korundum/bin/krubyinit.cpp
+@@ -31,6 +31,42 @@
+ // to detect what they were started with
+ static const char* script_name = "krubyinit_app";
+
++/*#ifdef __dilos__
++#include <tdeglobal.h>
++
++class TDEGlobalNetworkManager;
++class TDEGlobalNetworkManager;
++class TDEHardwareDevices;
++
++TDEGlobalNetworkManager *
++TDEInstance::networkManager()const
++{
++
++ return (NULL);
++}
++
++TDEHardwareDevices *
++TDEInstance::hardwareDevices()const
++{
++
++ return (NULL);
++}
++
++TDEGlobalNetworkManager *
++TDEGlobal::networkManager()
++{
++
++ return (NULL);
++}
++
++TDEHardwareDevices *
++TDEGlobal::hardwareDevices()
++{
++
++ return (NULL);
++}
++#endif*/ /* __dilos__ */
++
+ int main(int argc, char **argv) {
+ ruby_init();
+ ruby_script((char*)script_name);
+Index: tdebindings/smoke/tde/Makefile.am
+===================================================================
+--- tdebindings.orig/smoke/tde/Makefile.am
++++ tdebindings/smoke/tde/Makefile.am
+@@ -1,3 +1,4 @@
++CPPFLAGS+= -D__TDE_HAVE_TDEHWLIB
+ lib_LTLIBRARIES = libsmoketde.la
+
+ # set the include path for X, qt and KDE
+@@ -16,11 +17,15 @@ x_sources = x_1.cpp x_2.cpp x_3.cpp x_4
+ x_16.cpp x_17.cpp x_18.cpp x_19.cpp x_20.cpp
+
+ # which sources should be compiled for perlqttde
+-libsmoketde_la_SOURCES = $(x_sources) smokedata.cpp
++libsmoketde_la_SOURCES = $(x_sources) smokedata.cpp dilos_smoke_tde.cpp
+
+ $(x_sources) smokedata.cpp:
+ perl generate.pl
+
++dilos_smoke_tde.cpp:
++ cp -f $(top_srcdir)/debian/local/$@ $@
++
+ CLEANFILES = $(libsmoketde_la_SOURCES)
+
+ .NOTPARALLEL:
++
+Index: tdebindings/admin/acinclude.m4.in
+===================================================================
+--- tdebindings.orig/admin/acinclude.m4.in
++++ tdebindings/admin/acinclude.m4.in
+@@ -1586,7 +1586,7 @@ if AC_TRY_EVAL(kde_line); then
+ # if you're trying to debug this check and think it's incorrect,
+ # better check your installation. The check _is_ correct - your
+ # installation is not.
+- if test -f actest.cpp && grep klineedit actest.cpp > /dev/null; then
++ if test -f actest.cpp && grep -i klineedit actest.cpp > /dev/null; then
+ kde_cv_uic_plugins=yes
+ fi
+ fi
+Index: tdebindings/kjsembed/docs/embedding/simple-embed/embedview.ui
+===================================================================
+--- tdebindings.orig/kjsembed/docs/embedding/simple-embed/embedview.ui
++++ tdebindings/kjsembed/docs/embedding/simple-embed/embedview.ui
+@@ -180,4 +180,7 @@
+ <includehint>kpushbutton.h</includehint>
+ <includehint>kpushbutton.h</includehint>
+ </includehints>
++<includes>
++ <include>kpushbutton.h</include>
++</includes>
+ </UI>