summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kcmldap/kcmldap-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
commita615d19df88eb2e989316b480519161945dbc7dc (patch)
tree369970b98042998b86c11024598155e037b76fec /redhat/applications/kcmldap/kcmldap-14.0.0.spec
parent76a93e0011ade1583a1ec672f33411dfd35454f3 (diff)
downloadtde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.tar.gz
tde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.zip
RPM: merge redhat directory with master branch
Diffstat (limited to 'redhat/applications/kcmldap/kcmldap-14.0.0.spec')
-rw-r--r--redhat/applications/kcmldap/kcmldap-14.0.0.spec151
1 files changed, 109 insertions, 42 deletions
diff --git a/redhat/applications/kcmldap/kcmldap-14.0.0.spec b/redhat/applications/kcmldap/kcmldap-14.0.0.spec
index b2b6646ce..b8fd4cc4b 100644
--- a/redhat/applications/kcmldap/kcmldap-14.0.0.spec
+++ b/redhat/applications/kcmldap/kcmldap-14.0.0.spec
@@ -1,47 +1,62 @@
-# Default version for this component
-%define tde_pkg kcmldap
+#
+# spec file for package kcmldap (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kcmldap
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: Kerberos control module for the TDE control center
+Epoch: %{tde_epoch}
Version: 0.5
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Kerberos control module for the TDE control center
Group: Applications/Utilities
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.trinitydesktop.org/
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
@@ -49,8 +64,56 @@ BuildRequires: desktop-file-utils
BuildRequires: gettext
BuildRequires: trinity-libtdeldap-devel >= 0.5
-Requires: trinity-tde-ldap-cert-updater = %{version}-%{release}
-Requires: trinity-kcontrol-ldap-bonding = %{version}-%{release}
+Requires: trinity-tde-ldap-cert-updater = %{?epoch:%{epoch}:}%{version}-%{release}
+Requires: trinity-kcontrol-ldap-bonding = %{?epoch:%{epoch}:}%{version}-%{release}
+
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# OPENLDAP support
+%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: openldap-devel
+%endif
+%if 0%{?suse_version}
+BuildRequires: openldap2-devel
+%endif
+%if 0%{?rhel} == 5
+BuildRequires: openldap24-libs-devel
+%endif
+
+# HEIMDAL support
+%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: heimdal-devel
+%endif
+%if 0%{?suse_version}
+BuildRequires: libheimdal-devel
+%endif
+
+# UDEV support
+%if 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version} || 0%{?rhel} >= 6
+%define with_tdehwlib 1
+BuildRequires: libudev-devel
+%endif
+
+# LIBCOM_ERR support
+%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 6
+BuildRequires: libcom_err-devel
+%endif
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}ext2fs-devel
+%endif
+
%description
This is a meta-package that installs all kcmldap related packages.
@@ -62,17 +125,11 @@ This is a meta-package that installs all kcmldap related packages.
%package -n trinity-kcontrol-ldap-bonding
Summary: Kerberos control module for the TDE control center
Group: Applications/Utilities
-Requires: trinity-tde-ldap-cert-updater = %{version}-%{release}
+Requires: trinity-tde-ldap-cert-updater = %{?epoch:%{epoch}:}%{version}-%{release}
%description -n trinity-kcontrol-ldap-bonding
This is a TDE control center module to manage TDE connections to Kerberos realms.
-%post -n trinity-kcontrol-ldap-bonding
-touch --no-create %{tde_datadir}/icons/hicolor || :
-
-%postun -n trinity-kcontrol-ldap-bonding
-touch --no-create %{tde_datadir}/icons/hicolor || :
-
%files -n trinity-kcontrol-ldap-bonding
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING
@@ -80,6 +137,7 @@ touch --no-create %{tde_datadir}/icons/hicolor || :
%{tde_tdelibdir}/kcm_ldapbonding.la
%{tde_tdelibdir}/kcm_ldapbonding.so
%{tde_tdeappdir}/ldapbonding.desktop
+%dir %{tde_datadir}/pixmaps
%{tde_datadir}/pixmaps/kcmldapbonding_step1.png
%{tde_datadir}/pixmaps/kcmldapbonding_step3.png
@@ -88,17 +146,11 @@ touch --no-create %{tde_datadir}/icons/hicolor || :
%package -n trinity-tde-ldap-cert-updater
Summary: Service to keep LDAP certificates up-to-date
Group: Applications/Utilities
-Requires: trinity-kcontrol-ldap-bonding = %{version}-%{release}
+Requires: trinity-kcontrol-ldap-bonding = %{?epoch:%{epoch}:}%{version}-%{release}
%description -n trinity-tde-ldap-cert-updater
This is a small daemon which keeps the LDAP root certificate up to date with the LDAP server
-%post -n trinity-tde-ldap-cert-updater
-touch --no-create %{tde_datadir}/icons/hicolor || :
-
-%postun -n trinity-tde-ldap-cert-updater
-touch --no-create %{tde_datadir}/icons/hicolor || :
-
%files -n trinity-tde-ldap-cert-updater
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING
@@ -106,23 +158,37 @@ touch --no-create %{tde_datadir}/icons/hicolor || :
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
+
+extra_includes="%{_includedir}"
+extra_libs="%{_libdir}"
+
+if [ -d "%{_includedir}/openldap24" ]; then
+ extra_includes="%{_includedir}/openldap24:${extra_includes}"
+ extra_libs="%{_libdir}/openldap24:${extra_libs}"
+fi
+
+if [ -d "%{_includedir}/heimdal" ]; then
+ extra_includes="%{_includedir}/heimdal:${extra_includes}"
+ extra_libs="%{_libdir}/heimdal:${extra_libs}"
+fi
%configure \
--prefix=%{tde_prefix} \
@@ -139,7 +205,10 @@ export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
--enable-final \
--enable-closure \
--enable-rpath \
- --disable-gcc-hidden-visibility
+ --disable-gcc-hidden-visibility \
+ \
+ --with-extra-includes=${extra_includes} \
+ --with-extra-libs=${extra_libs} \
%__make %{?_smp_mflags}
@@ -155,5 +224,3 @@ export PATH="%{tde_bindir}:${PATH}"
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.5-1
-- Initial release for TDE 14.0.0