summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tellico/tellico-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
commita615d19df88eb2e989316b480519161945dbc7dc (patch)
tree369970b98042998b86c11024598155e037b76fec /redhat/applications/tellico/tellico-14.0.0.spec
parent76a93e0011ade1583a1ec672f33411dfd35454f3 (diff)
downloadtde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.tar.gz
tde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.zip
RPM: merge redhat directory with master branch
Diffstat (limited to 'redhat/applications/tellico/tellico-14.0.0.spec')
-rw-r--r--redhat/applications/tellico/tellico-14.0.0.spec301
1 files changed, 197 insertions, 104 deletions
diff --git a/redhat/applications/tellico/tellico-14.0.0.spec b/redhat/applications/tellico/tellico-14.0.0.spec
index 26b065bdc..8cb0aae90 100644
--- a/redhat/applications/tellico/tellico-14.0.0.spec
+++ b/redhat/applications/tellico/tellico-14.0.0.spec
@@ -1,61 +1,121 @@
-# Default version for this component
-%define tde_pkg tellico
-%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
+%if 0%{?fedora} >= 23
+%define _hardened_ldflags %nil
%endif
-# TDE specific building variables
+#
+# spec file for package tellico (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
+%endif
+%define tde_pkg tellico
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_tdedocdir}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.3.2.1
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Icollection manager for books, videos, music [Trinity]
+Group: Applications/Utilities
+URL: http://periapsis.org/tellico/
-Name: trinity-%{tde_pkg}
-Summary: Icollection manager for books, videos, music [Trinity]
-Version: 1.3.2.1
-Release: %{?!preversion:8}%{?preversion:7_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://periapsis.org/tellico/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-Patch1: tellico-3.5.13.2-videodev.patch
-
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: trinity-tdemultimedia-devel >= %{tde_version}
+BuildRequires: trinity-libkcal-devel >= %{tde_version}
+BuildRequires: trinity-libpoppler-tqt-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+BuildRequires: cmake >= 2.8
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# POPPLER support
+%if 0%{?rhel} >=6 || 0%{?fedora} >= 15 || 0%{?suse_version}
+%if 0%{?suse_version} >= 1500
+BuildRequires: libpoppler-devel >= 0.12
+%else
+BuildRequires: poppler-devel >= 0.12
+%endif
+%endif
+%if 0%{?mgaversion} || 0%{?mdkversion}
+BuildRequires: %{_lib}poppler-devel
+%endif
+%if 0%{?rhel} >= 4 && 0%{?rhel} <= 5
+# On RHEL 5, the distro-provided poppler is too old. We built a newer one.
+BuildRequires: trinity-poppler-devel >= 0.12
+%endif
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# YAZ support
%if 0%{?mgaversion} || 0%{?mdkversion}
BuildRequires: yaz
BuildRequires: %{_lib}yaz-devel
%endif
+# XML2 support
+BuildRequires: libxml2-devel
+
+# XSLT support
+BuildRequires: libxslt-devel
+%if 0%{?rhel} == 4
+# a bogus dep in libexslt.la file from EL-4 (WONTFIX bug http://bugzilla.redhat.com/142241)
+BuildRequires: libgcrypt-devel
+%endif
+
# V4L support
%if 0%{?rhel} >= 6 || 0%{?fedora} >= 15 || 0%{?suse_version}
BuildRequires: libv4l-devel
@@ -64,8 +124,39 @@ BuildRequires: libv4l-devel
BuildRequires: %{_lib}v4l-devel
%endif
-Requires: %{name}-data = %{version}-%{release}
-Requires: %{name}-scripts = %{version}-%{release}
+# EXEMPI support
+%if 0%{?suse_version}
+BuildRequires: libexempi-devel
+%else
+BuildRequires: exempi-devel
+%endif
+
+# PCRE support
+BuildRequires: pcre-devel
+
+# IDN support
+BuildRequires: libidn-devel
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+
+# OPENSSL support
+BuildRequires: openssl-devel
+
+# ACL support
+BuildRequires: libacl-devel
+
+# ATTR support
+BuildRequires: libattr-devel
+
+
+Requires: %{name}-data = %{?epoch:%{epoch}:}%{version}-%{release}
+Requires: %{name}-scripts = %{?epoch:%{epoch}:}%{version}-%{release}
+
%description
Tellico is a collection manager for TDE. It includes default collections for
@@ -81,6 +172,13 @@ or any US-MARC compliant z39.50 server.
The files are stored in XML format, avoiding the need for database server.
It also makes it easy for other softwares to use the Tellico data.
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%{tde_bindir}/tellico
+%{tde_datadir}/applications
+%{tde_confdir}/tellicorc
+
+##########
%package data
Group: Applications/Utilities
@@ -103,6 +201,35 @@ It also makes it easy for other softwares to use the Tellico data.
This package contains the architecture independent files, such data files and
documentation.
+%files data
+%defattr(-,root,root,-)
+%dir %{tde_datadir}/apps/tellico
+%{tde_datadir}/apps/tellico/*.xsl
+%{tde_datadir}/apps/tellico/*.xml
+%{tde_datadir}/apps/tellico/*.png
+%{tde_datadir}/apps/tellico/entry-templates
+%{tde_datadir}/apps/tellico/*.py*
+%{tde_datadir}/apps/tellico/pics
+%{tde_datadir}/apps/tellico/report-templates
+%{tde_datadir}/apps/tellico/tellico.dtd
+%{tde_datadir}/apps/tellico/tellico.tips
+%{tde_datadir}/apps/tellico/tellico2html.js
+%{tde_datadir}/apps/tellico/tellicoui.rc
+%{tde_datadir}/apps/tellico/welcome.html
+%{tde_datadir}/config.kcfg
+%{tde_tdedocdir}/HTML/*/tellico/
+%{tde_datadir}/icons/hicolor/*/apps/tellico.png
+%{tde_datadir}/icons/hicolor/*/mimetypes/application-x-tellico.png
+%{tde_datadir}/icons/hicolor/scalable/apps/tellico.svg
+%{tde_datadir}/icons/hicolor/scalable/mimetypes/application-x-tellico.svg
+%{tde_datadir}/mime/packages/tellico.xml
+%{tde_datadir}/mimelnk/application/x-tellico.desktop
+%{tde_datadir}/apps/tdeconf_update/tellico-1-3-update.pl
+%{tde_datadir}/apps/tdeconf_update/tellico-rename.upd
+%{tde_datadir}/apps/tdeconf_update/tellico.upd
+
+##########
+
%package scripts
Group: Applications/Utilities
Summary: collection manager for books, videos, music [scripts] [Trinity]
@@ -125,47 +252,60 @@ This package contains the scripts to import data from external sources, such
as websites. As the format of the data may change, these scripts are provided
as a separate package which can be updated through debian-volatile.
+%files scripts
+%defattr(-,root,root,-)
+%{tde_datadir}/apps/tellico/data-sources
+%{tde_datadir}/apps/tellico/z3950-servers.cfg
+
+##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
if [ -r /usr/include/libv4l1-videodev.h ]; then
-%patch1 -p1 -b .videodev
+%__sed -i "src/barcode/barcode_v4l.h" -e "s|linux/videodev.h|libv4l1.h|"
fi
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-# Warning, --enable-final causes FTBFS !
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
- --includedir=%{tde_tdeincludedir} \
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+# Warning: GCC visibility causes FTBFS [Bug #1285]
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_NO_BUILTIN_CHRPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
\
- --disable-dependency-tracking \
- --disable-debug \
- --disable-final \
- --enable-new-ldflags \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility \
+ -DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
\
- --enable-webcam
+ -DWITH_ALL_OPTIONS=ON \
+ -DWITH_LIBKCDDB=ON \
+ -DWITH_LIBKCAL=ON \
+ -DWITH_LIBBTPARSE=OFF \
+ -DWITH_SAX_LOADER=ON \
+ ..
%__make %{?_smp_mflags} || %__make
@@ -173,11 +313,11 @@ export PATH="%{tde_bindir}:${PATH}"
%install
export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
+%__make install DESTDIR=$RPM_BUILD_ROOT -C build
# Add svg icons to xdg directories
-%__install -D -c -p -m 644 icons/tellico.svg %{?buildroot}%{tde_datadir}/icons/hicolor/scalable/apps/tellico.svg
-%__install -D -c -p -m 644 icons/tellico_mime.svg %{?buildroot}%{tde_datadir}/icons/hicolor/scalable/mimetypes/application-x-tellico.svg
+%__install -D -c -p -m 644 "icons/tellico.svg" "%{?buildroot}%{tde_datadir}/icons/hicolor/scalable/apps/tellico.svg"
+%__install -D -c -p -m 644 "icons/tellico_mime.svg" "%{?buildroot}%{tde_datadir}/icons/hicolor/scalable/mimetypes/application-x-tellico.svg"
%find_lang %{tde_pkg}
@@ -186,51 +326,4 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%{tde_bindir}/tellico
-#%{tde_datadir}/pixmaps
-%{tde_datadir}/applications
-%{tde_datadir}/config/tellicorc
-
-%files data
-%defattr(-,root,root,-)
-%{tde_datadir}/apps/tellico/*.xsl
-%{tde_datadir}/apps/tellico/*.xml
-%{tde_datadir}/apps/tellico/*.png
-%{tde_datadir}/apps/tellico/entry-templates
-%{tde_datadir}/apps/tellico/*.py*
-%{tde_datadir}/apps/tellico/pics
-%{tde_datadir}/apps/tellico/report-templates
-%{tde_datadir}/apps/tellico/tellico.dtd
-%{tde_datadir}/apps/tellico/tellico.tips
-%{tde_datadir}/apps/tellico/tellico2html.js
-%{tde_datadir}/apps/tellico/tellicoui.rc
-%{tde_datadir}/apps/tellico/welcome.html
-%{tde_datadir}/config.kcfg
-%{tde_tdedocdir}/HTML/*/tellico/
-%{tde_datadir}/icons
-%{tde_datadir}/apps/mime
-%{tde_datadir}/mimelnk
-%{tde_datadir}/apps/tdeconf_update/tellico-1-3-update.pl
-%{tde_datadir}/apps/tdeconf_update/tellico-rename.upd
-%{tde_datadir}/apps/tdeconf_update/tellico.upd
-
-%files scripts
-%defattr(-,root,root,-)
-%{tde_datadir}/apps/tellico/data-sources
-%{tde_datadir}/apps/tellico/z3950-servers.cfg
-
-
%changelog
-* Mon Jul 29 2013 Francois Andriot <francois.andriot@free.fr> - 1.3.2.1-8
-- Initial release for TDE 14.0.0