summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/development/piklab/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-05-07 19:02:31 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-05-07 19:02:31 +0900
commit81ae412a67476f0c72cdddd2b26385304f26be18 (patch)
tree29205a32fa98911d33842022028a7d400dc0b4dd /ubuntu/_base/applications/development/piklab/debian/rules
parent6e966d18f421ef993425460f5a392f0af7096c6a (diff)
downloadtde-packaging-81ae412a67476f0c72cdddd2b26385304f26be18.tar.gz
tde-packaging-81ae412a67476f0c72cdddd2b26385304f26be18.zip
DEB piklab: switch to cmake building system
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/development/piklab/debian/rules')
-rwxr-xr-xubuntu/_base/applications/development/piklab/debian/rules21
1 files changed, 12 insertions, 9 deletions
diff --git a/ubuntu/_base/applications/development/piklab/debian/rules b/ubuntu/_base/applications/development/piklab/debian/rules
index 5b220ac67..a6797f19a 100755
--- a/ubuntu/_base/applications/development/piklab/debian/rules
+++ b/ubuntu/_base/applications/development/piklab/debian/rules
@@ -1,14 +1,17 @@
#!/usr/bin/make -f
-# Currently is not possible to build piklab with --enable-final
-DEB_BUILD_OPTIONS += noopt
-
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"