summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kio-apt/debian/fixrpath
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
commitaf5c905ec49085b7c396caf2c5166f0c34cbeb3f (patch)
tree56463d31ace48f127ed61169fdc2b4b8aedfcc56 /ubuntu/_base/applications/kio-apt/debian/fixrpath
parente43172a6e74706afc06ff8d11cbfa769bc949cc1 (diff)
downloadtde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.tar.gz
tde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/kio-apt/debian/fixrpath')
-rwxr-xr-xubuntu/_base/applications/kio-apt/debian/fixrpath25
1 files changed, 25 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kio-apt/debian/fixrpath b/ubuntu/_base/applications/kio-apt/debian/fixrpath
new file mode 100755
index 000000000..0ca44359e
--- /dev/null
+++ b/ubuntu/_base/applications/kio-apt/debian/fixrpath
@@ -0,0 +1,25 @@
+#!/bin/sh
+# $Id: fixrpath,v 1.1 2006/11/19 12:01:24 lpnotfr Exp $
+# libtool -rpath workaround based on a suggestion by Yann Dirson
+# <dirson@debian.org>
+#
+# It is supposed to be inserted in configure.in, but I didn't want
+# to re-run autoconf (since that bloats the Debian diff unnecessarily),
+# so I just patch libtool after running configure. -- Richard Braakman
+# <dark@xs4all.nl>
+#
+# The version of libtool included with LessTif unfortunately insists on
+# linking with -rpath, i.e. hardwiring locations. This is not desirable.
+#
+# The dummy define is improbable enough not to conflict with anything; it is
+# just here to fool libtool by making it believe it gave some useful info to
+# gcc.
+#
+# This will also patch the generated libtool to explicitly
+# link libraries against the libraries they depend on. (particularly libc)
+
+sed < $1/libtool > $1/libtool-2 \
+ -e 's/^hardcode_libdir_flag_spec.*$/hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ "/' \
+ -e '/^archive_cmds="/s/"$/ \$deplibs"/'
+mv $1/libtool-2 $1/libtool
+chmod 755 $1/libtool