summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/multimedia/soundkonverter/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
commitbd72eef4a4458f8d2e52609d7b6cf3efe12a0177 (patch)
treeb797d29ee85d482247cfecda13d1fb572e4c4d62 /ubuntu/_base/applications/multimedia/soundkonverter/debian/rules
parent5051f08d847e70346920d72e34da55558b89145c (diff)
downloadtde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.tar.gz
tde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/multimedia/soundkonverter/debian/rules')
-rwxr-xr-xubuntu/_base/applications/multimedia/soundkonverter/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/multimedia/soundkonverter/debian/rules b/ubuntu/_base/applications/multimedia/soundkonverter/debian/rules
new file mode 100755
index 000000000..fa0a1f580
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/soundkonverter/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_INSTALL_ARGS = --sourcedir=debian/tmp
+DEB_CONFIGURE_EXTRA_FLAGS = --with-extra-libs=/opt/trinity/lib
+
+install/soundkonverter-trinity::
+ install -D -p -m0644 debian/soundkonverter-trinity.lintian-overrides \
+ debian/soundkonverter-trinity/usr/share/lintian/overrides/soundkonverter-trinity
+
+install/soundkonverter-amarok-trinity::
+ chmod 0755 debian/tmp/opt/trinity/share/apps/soundkonverter/amarokscript/soundKonverter.rb
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap