summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/smartcardauth/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
commitbd72eef4a4458f8d2e52609d7b6cf3efe12a0177 (patch)
treeb797d29ee85d482247cfecda13d1fb572e4c4d62 /ubuntu/_base/applications/system/smartcardauth/debian/rules
parent5051f08d847e70346920d72e34da55558b89145c (diff)
downloadtde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.tar.gz
tde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/system/smartcardauth/debian/rules')
-rwxr-xr-xubuntu/_base/applications/system/smartcardauth/debian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/smartcardauth/debian/rules b/ubuntu/_base/applications/system/smartcardauth/debian/rules
new file mode 100755
index 000000000..14ccf6018
--- /dev/null
+++ b/ubuntu/_base/applications/system/smartcardauth/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+
+DEB_BUILD_OPTIONS := nostrip
+export DEB_BUILD_OPTIONS = debug nostrip
+
+CFLAGS=-g -Wall -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR="$(DEB_DESTDIR)"
+DEB_INSTALL_DOCS_ALL :=
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DWITH_ALL_OPTIONS="ON"