summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tdepacman/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-09-05 21:05:32 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-09-05 21:44:35 +0900
commiteaeaf24bfb9f7e598c1f9245531e5c041b44b8ad (patch)
tree1d9a06aef83c08d2bb6cf3f44c3eabd8b5a7296e /ubuntu/_base/applications/tdepacman/debian/rules
parent5d9b7f5acb73ae18aa7079a43f8a4cbd991cb363 (diff)
downloadtde-packaging-eaeaf24bfb9f7e598c1f9245531e5c041b44b8ad.tar.gz
tde-packaging-eaeaf24bfb9f7e598c1f9245531e5c041b44b8ad.zip
DEB: added tdepacman.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit d425b2fe099bd6fd6dde67f7adf2123f66d3ede7)
Diffstat (limited to 'ubuntu/_base/applications/tdepacman/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tdepacman/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/tdepacman/debian/rules b/ubuntu/_base/applications/tdepacman/debian/rules
new file mode 100755
index 000000000..cee2a3058
--- /dev/null
+++ b/ubuntu/_base/applications/tdepacman/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"