summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdeaccessibility/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-15 19:23:30 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-15 19:23:30 +0800
commit0277521b268b21caf0ee21202b92784f302baadc (patch)
tree5d856f96adfbe46b57da31cf60daa1084b4e7a1e /ubuntu/_base/core/tdeaccessibility/debian/rules
parenteb16e7c7281e182297581fa8d565561869c81bca (diff)
downloadtde-packaging-0277521b268b21caf0ee21202b92784f302baadc.tar.gz
tde-packaging-0277521b268b21caf0ee21202b92784f302baadc.zip
DEB: adjusted to new 'core' folder for main packages.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/core/tdeaccessibility/debian/rules')
-rwxr-xr-xubuntu/_base/core/tdeaccessibility/debian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/ubuntu/_base/core/tdeaccessibility/debian/rules b/ubuntu/_base/core/tdeaccessibility/debian/rules
new file mode 100755
index 000000000..9e4e2c943
--- /dev/null
+++ b/ubuntu/_base/core/tdeaccessibility/debian/rules
@@ -0,0 +1,25 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --enable-ksayit-audio-plugins --with-akode --prefix=/opt/trinity \
+ --with-extra-libs=/opt/trinity/lib
+
+DEB_DH_STRIP_ARGS := --dbg-package=tdeaccessibility-trinity-dbg
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+PACKAGES_WITH_LIBS := kttsd-trinity ksayit-trinity
+
+#shlibs_ver = 4:3.5.0
+#$(foreach p,$(PACKAGES_WITH_LIBS),$(eval DEB_DH_MAKESHLIBS_ARGS_$(p) := -V'$(p) (>= $(shlibs_ver))'))