summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/libraries/pytde/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-01-03 15:48:09 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-01-08 21:02:25 +0900
commit328096e4edbd37b6e5b012cef3c78e311f26655f (patch)
treeb78af02b0cb73c40d7270efa939a4d5d72532b35 /ubuntu/_base/libraries/pytde/debian/rules
parentf963f7aac5a1c2cd3f09dfb5dc14e16fc1f7c7a6 (diff)
downloadtde-packaging-328096e4edbd37b6e5b012cef3c78e311f26655f.tar.gz
tde-packaging-328096e4edbd37b6e5b012cef3c78e311f26655f.zip
DEB pytde: drop python 2 support.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/libraries/pytde/debian/rules')
-rwxr-xr-xubuntu/_base/libraries/pytde/debian/rules35
1 files changed, 17 insertions, 18 deletions
diff --git a/ubuntu/_base/libraries/pytde/debian/rules b/ubuntu/_base/libraries/pytde/debian/rules
index 5cf2cd446..92d121fac 100755
--- a/ubuntu/_base/libraries/pytde/debian/rules
+++ b/ubuntu/_base/libraries/pytde/debian/rules
@@ -1,5 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -21,10 +20,14 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
endif
-# This has to be exported to make some magic below work.
+export DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+export DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
export DH_OPTIONS
-export QTDIR=/usr/share/qt3
-export QMAKESPEC=$(QTDIR)/mkspecs/linux-g++
+
+export TQTDIR=/usr/share/tqt3
+export QMAKESPEC=$(TQTDIR)/mkspecs/linux-g++
CXXFLAGS = -Wall -g
@@ -34,10 +37,8 @@ else
CXXFLAGS += -O2
endif
-PYTHONS := $(shell pyversions -vr debian/control)
-DBG_PYTHONS := $(shell pyversions -vd)
-
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
+PYTHONS := $(shell py3versions -vd)
+DBG_PYTHONS := $(shell py3versions -vd)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -55,7 +56,6 @@ build-%/configure-stamp:
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
-c -u -k /opt/trinity -o /opt/trinity/include -n /opt/trinity/lib \
- -e python$* \
-v /usr/share/sip-tqt/trinity -j $(SPLIT)
touch $@
@@ -64,7 +64,6 @@ dbg-build-%/configure-stamp:
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
-c -u -k /opt/trinity -o /opt/trinity/include -n /opt/trinity/lib \
- -e python$* \
-v /usr/share/sip-tqt/trinity -j $(SPLIT)
touch $@
@@ -130,21 +129,21 @@ install-arch:
set -e; \
for version in ${DBG_PYTHONS}; do \
- $(MAKE) -C dbg-build-$$version install DESTDIR=$(CURDIR)/debian/python-pytde-dbg;\
+ $(MAKE) -C dbg-build-$$version install DESTDIR=$(CURDIR)/debian/python3-pytde-dbg;\
done
dh_install -a --sourcedir=$(CURDIR)/debian/tmp
- mkdir -p $(CURDIR)/debian/python-pytde/opt/trinity/lib/
- ln -s /opt/trinity/lib/trinity/libkonsolepart.so $(CURDIR)/debian/python-ptde/opt/trinity/lib/
- for i in $$(find debian/python-*-dbg -name '*.so'); do \
+ mkdir -p $(CURDIR)/debian/python3-pytde/opt/trinity/lib/
+ ln -s /opt/trinity/lib/trinity/libkonsolepart.so $(CURDIR)/debian/python3-pytde/opt/trinity/lib/
+ for i in $$(find debian/python3-*-dbg -name '*.so'); do \
b=$$(basename $$i .so); \
mv $$i $$(dirname $$i)/$${b}_d.so; \
done
- find debian/python-*-dbg ! -type d \
+ find debian/python3-*-dbg ! -type d \
! \( -name '*.so' -o -name '*config_d.py' \) | xargs rm -f
- find debian/python-*-dbg -depth -type d -empty -exec rmdir {} \;
+ find debian/python3-*-dbg -depth -type d -empty -exec rmdir {} \;
# Must not depend on anything. This is to be called by
@@ -158,11 +157,11 @@ binary-common:
dh_installexamples
dh_link
ifeq (,$(findstring -i, $(DH_OPTIONS)))
- DH_OPTIONS= dh_strip -ppython-pytde #--dbg-package=python-pytde-dbg
+ DH_OPTIONS= dh_strip -ppython3-pytde #--dbg-package=python3-pytde-dbg
endif
dh_compress -X.py -X.ui -X.dtd
dh_fixperms
- ${DH_PYTHON2}
+ dh_python3 --no-dbg-cleaning
dh_installdeb
dh_shlibdeps -l /opt/trinity/lib
dh_gencontrol