summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/filelight/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-01-23 02:11:10 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-01-23 02:11:10 +0100
commit2fd1fd42c1dd05644bdd5893c20ffa7801e9c6a0 (patch)
treec9033e53e967b59b827f70f6ed40d9b6f308eed7 /ubuntu/maverick/applications/filelight/debian/rules
parent2aeabd1b78538a0d612a78bb6940252d2a2496f2 (diff)
downloadtde-packaging-2fd1fd42c1dd05644bdd5893c20ffa7801e9c6a0.tar.gz
tde-packaging-2fd1fd42c1dd05644bdd5893c20ffa7801e9c6a0.zip
Switch filelight to cmake on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/filelight/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/filelight/debian/rules32
1 files changed, 12 insertions, 20 deletions
diff --git a/ubuntu/maverick/applications/filelight/debian/rules b/ubuntu/maverick/applications/filelight/debian/rules
index d023c8d99..f296f481e 100755
--- a/ubuntu/maverick/applications/filelight/debian/rules
+++ b/ubuntu/maverick/applications/filelight/debian/rules
@@ -5,36 +5,28 @@
# see /usr/share/common-licenses/GPL-2 for details.
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/kde.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
DEB_INSTALL_MANPAGES_filelight := debian/filelight.1
DEB_DH_ALWAYS_EXCLUDE=.svn
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --disable-debug
+# Build options
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-common-install-arch::
- rm -rf debian/filelight/usr/share/locale/
- rm -rf debian/filelight/usr/share/doc/tde/