summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kaffeine-mozilla/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:02:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:51:58 +0100
commit64aefa71763dd8803f9db537f4b16c24092ce763 (patch)
tree6a3d62e0a6c7d2aee9d0ecac288cd746d06f8714 /ubuntu/maverick/applications/kaffeine-mozilla/debian
parentd14557087bc123c802c56d30190a2c4f6151b586 (diff)
downloadtde-packaging-64aefa71763dd8803f9db537f4b16c24092ce763.tar.gz
tde-packaging-64aefa71763dd8803f9db537f4b16c24092ce763.zip
Use xz (or bzip2) compression for Debian and Ubuntu binary packages
(cherry picked from commit e12b7beacb145e0359e66ec5d4cfc0494d3ca908)
Diffstat (limited to 'ubuntu/maverick/applications/kaffeine-mozilla/debian')
-rwxr-xr-xubuntu/maverick/applications/kaffeine-mozilla/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/kaffeine-mozilla/debian/rules b/ubuntu/maverick/applications/kaffeine-mozilla/debian/rules
index 0fe0eb38e..08c10c248 100755
--- a/ubuntu/maverick/applications/kaffeine-mozilla/debian/rules
+++ b/ubuntu/maverick/applications/kaffeine-mozilla/debian/rules
@@ -14,6 +14,9 @@ export DH_OPTIONS
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
@@ -139,7 +142,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install